1. 程式人生 > >HDU2732:Leapin' Lizards(最大流)

HDU2732:Leapin' Lizards(最大流)

Leapin' Lizards

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4250    Accepted Submission(s): 1705

題目連結:http://acm.hdu.edu.cn/showproblem.php?pid=2732

Description:

Your platoon of wandering lizards has entered a strange room in the labyrinth you are exploring. As you are looking around for hidden treasures, one of the rookies steps on an innocent-looking stone and the room's floor suddenly disappears! Each lizard in your platoon is left standing on a fragile-looking pillar, and a fire begins to rage below... Leave no lizard behind! Get as many lizards as possible out of the room, and report the number of casualties.
The pillars in the room are aligned as a grid, with each pillar one unit away from the pillars to its east, west, north and south. Pillars at the edge of the grid are one unit away from the edge of the room (safety). Not all pillars necessarily have a lizard. A lizard is able to leap onto any unoccupied pillar that is within d units of his current one. A lizard standing on a pillar within leaping distance of the edge of the room may always leap to safety... but there's a catch: each pillar becomes weakened after each jump, and will soon collapse and no longer be usable by other lizards. Leaping onto a pillar does not cause it to weaken or collapse; only leaping off of it causes it to weaken and eventually collapse. Only one lizard may be on a pillar at any given time.

Input:

The input file will begin with a line containing a single integer representing the number of test cases, which is at most 25. Each test case will begin with a line containing a single positive integer n representing the number of rows in the map, followed by a single non-negative integer d representing the maximum leaping distance for the lizards. Two maps will follow, each as a map of characters with one row per line. The first map will contain a digit (0-3) in each position representing the number of jumps the pillar in that position will sustain before collapsing (0 means there is no pillar there). The second map will follow, with an 'L' for every position where a lizard is on the pillar and a '.' for every empty pillar. There will never be a lizard on a position where there is no pillar.Each input map is guaranteed to be a rectangle of size n x m, where 1 ≤ n ≤ 20 and 1 ≤ m ≤ 20. The leaping distance is
always 1 ≤ d ≤ 3.

Output:

For each input case, print a single line containing the number of lizards that could not escape. The format should follow the samples provided below.

Sample Input:

4 3 1 1111 1111 1111 LLLL LLLL LLLL 3 2 00000 01110 00000 ..... .LLL. ..... 3 1 00000 01110 00000 ..... .LLL. ..... 5 2 00000000 02000000 00321100 02000000 00000000 ........ ........ ..LLLL.. ........ ........

Sample Output:

Case #1: 2 lizards were left behind. Case #2: no lizard was left behind. Case #3: 3 lizards were left behind. Case #4: 1 lizard was left behind.

題意:

給出一個n*m的矩陣,輸入兩次,第一次表示上面的柱子,如果有數值,就代表這根柱子最多隻能被幾隻蜥蜴上來過;第二次如果有L,這代表這個位置有隻蜥蜴。

會給出蜥蜴的最大跳躍距離d,當然可以跳多次,只能跳到柱子上。問最多有多少隻蜥蜴可以跳出這個矩陣。

 

題解:

考慮最大流,可以這樣建圖:

首先將每個柱子拆點,邊權為柱子的最大容量。

然後預處理能跳出矩陣的格子(有柱子),讓匯點與這些格子的出度點連邊,邊權為INF;然後遍歷這個圖,對能互相跳的柱子連邊,一個柱子的出度點連續另一個柱子的入讀點,邊權為INF。

最後讓源點與每個蜥蜴連邊,權值為1。

最後跑個最大流這題基本就完了~最後要注意下輸出...

 

程式碼如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <queue>
#include <cmath>
#define INF 99999999
#define t 1000
using namespace std;

const int N = 30;
int T,Case,tot,D,n,m;
int head[1005],d[1005],cur[1005];
int map[N][N];

struct Edge{
    int v,next,c;
}e[500000];
void adde(int u,int v,int c){
    e[tot].v=v;e[tot].c=c;e[tot].next=head[u];head[u]=tot++;
    e[tot].v=u;e[tot].c=0;e[tot].next=head[v];head[v]=tot++;
}
int dis(int x1,int y1,int x2,int y2){
    return abs(x1-x2)+abs(y1-y2);
}
bool bfs(int S,int T){
    memset(d,0,sizeof(d));d[S]=1;
    queue <int > q;q.push(S);
    while(!q.empty()){
        int u=q.front();q.pop();
        for(int i=head[u];i!=-1;i=e[i].next){
            int v=e[i].v;
            if(!d[v] && e[i].c>0){
                d[v]=d[u]+1;
                q.push(v);
            }
        }
    }
    return d[T]!=0;
}
int dfs(int s,int a){
    int flow=0,f;
    if(s==t || a==0) return a;
    for(int &i=cur[s];i!=-1;i=e[i].next){
        int v=e[i].v;
        if(d[v]!=d[s]+1) continue ;
        f=dfs(v,min(a,e[i].c));
        if(f){
            e[i].c-=f;
            e[i^1].c+=f;
            flow+=f;
            a-=f;
            if(a==0) break;
        }
    }
    if(!flow) d[s]=-1;
    return flow;
}
int Dinic(){
    int max_flow=0;
    while(bfs(0,t)){
        for(int i=0;i<=t;i++) cur[i]=head[i];
        max_flow+=dfs(0,INF);
    }
    return max_flow;
}
int main(){
    scanf("%d",&T);
    while(T--){
        Case++;
        tot=0;memset(head,-1,sizeof(head));
        scanf("%d%d",&n,&D);
        char s[N];
        for(int i=1;i<=n;i++){
            scanf("%s",s);
            m = strlen(s);
            for(int j=0;j<m;j++){
                if(s[j]==0) continue ;
                map[i][j+1]=s[j]-'0';
                if(i<=D || n-i+1<=D || j+1<=D || m-j<=D){
                    int u = (i-1)*m+j+1;
                    adde(u+400,t,map[i][j+1]);
                }
            }
        }
        int sum = 0;
        for(int i=1;i<=n;i++)
            for(int j=1;j<=m;j++)
                if(map[i][j]) adde((i-1)*m+j,(i-1)*m+j+400,map[i][j]);
        for(int i=1;i<=n;i++){
            for(int j=1;j<=m;j++){
                if(map[i][j]){
                    for(int _i=max(1,i-3);_i<=min(n,i+3);_i++){
                        for(int _j=max(1,j-3);_j<=min(m,j+3);_j++){
                            if(!map[_i][_j] || (i==_i && j==_j)) continue ;
                            if(dis(i,j,_i,_j)<=D)
                                adde((i-1)*m+j+400,(_i-1)*m+_j,INF);
                        }
                    }
                }
            }
        }
        for(int i=1;i<=n;i++){
            scanf("%s",s);
            for(int j=1;j<=m;j++)
            if(s[j-1]=='L') adde(0,(i-1)*m+j,1),sum++;
        }
        int cnt=Dinic();
        int left = sum-cnt;
        if(!left) printf("Case #%d: no lizard was left behind.\n",Case);
        else if(left==1) printf("Case #%d: 1 lizard was left behind.\n",Case);
        else printf("Case #%d: %d lizards were left behind.\n",Case,left);
    }
    return 0;
}