1. 程式人生 > >HDU1010 Tempter of the Bone(DFS+奇偶剪枝原理)

HDU1010 Tempter of the Bone(DFS+奇偶剪枝原理)

Tempter of the Bone

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 149935    Accepted Submission(s): 39970 Problem Description

The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze. The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.

Input

The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following: 'X': a block of wall, which the doggie cannot enter; 'S': the start point of the doggie; 'D': the Door; or '.': an empty block. The input is terminated with three 0's. This test case is not to be processed.

Output

For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.

Sample Input

4 4 5
S.X.
..X.
..XD
....
3 4 5
S.X.
..X.
...D
0 0 0

Sample Output

NO
YES

題目大意:第一行給出x,y,t,求從S能否剛好走t步到D。X表示牆  .表示路。S不一定在(0,0)位置。

題解:這一題只能用DFS寫,因為求的不是最短路徑,BFS只能求最短路徑。難點在於剪枝,這裡用到了奇偶剪枝原理。

奇偶剪枝原理:

要理解奇偶剪枝,先了解一下曼哈頓距離,從一個點到達另外一個點的最短路徑長度(時間)可以根據兩點座標求出,

路徑長度(非最短)與最短路徑的長度同奇偶,它們的差一定是偶數!

具體程式碼如下:

#include<iostream>
#include<queue>
#include<cstring>
#include<string>
#include<cmath>
using namespace std;
char map[8][8];
int d[4][2]={0,1,0,-1,1,0,-1,0};
int vis[8][8];
int n,m,t,dx,dy;
int OK;
void DFS(int x,int y,int step)
{
	if(map[x][y]=='D'&&step==t)
	{
		OK=1;
		return;
	}
	int time=t-step-(int)fabs(x-dx)-(int)fabs(y-dy);
    if (time<0||time%2!=0)
        return;	
	for(int i=0;i<4;i++)
	{
		int nx=x+d[i][0];
		int ny=y+d[i][1];
		if(nx<0||ny<0||nx>=n||ny>=m) continue;
		if(map[nx][ny]=='X') continue;
		if(vis[nx][ny]) continue;
		vis[nx][ny]=1;
		DFS(nx,ny,step+1);
		vis[nx][ny]=0;
		if(OK) return;
	}
}
int main()
{
	while(cin>>n>>m>>t&&(n+m+t)!=0)
	{
		memset(map,'X',sizeof(map));
		memset(vis,0,sizeof(vis));
		for(int i=0;i<n;i++)
				cin>>map[i];
		int sx,sy;
		for(int i=0;i<n;i++)
			for(int j=0;j<m;j++)
			{
				if(map[i][j]=='S')
				{
					sx=i;
					sy=j;
				}
				if(map[i][j]=='D')
				{
					dx=i;
					dy=j;
				}
			}
				
		OK=0;
		vis[sx][sy]=1;
		DFS(sx,sy,0);								
		if(OK)
			cout<<"YES"<<endl;
		else
			cout<<"NO"<<endl;			
	}
	return 0;
}