1. 程式人生 > >AC自動機模板題 (hdu2222)

AC自動機模板題 (hdu2222)

Problem Description

In the modern time, Search engine came into the life of everybody like Google, Baidu, etc. Wiskey also wants to bring this feature to his image retrieval system. Every image have a long description, when users type some keywords to find the image, the system will match the keywords with description of image and show the image which the most keywords be matched. To simplify the problem, giving you a description of image, and some keywords, you should tell me how many keywords will be match.

Input

First line will contain one integer means how many cases will follow by. Each case will contain two integers N means the number of keywords and N keywords follow. (N <= 10000) Each keyword will only contains characters 'a'-'z', and the length will be not longer than 50. The last line is the description, and the length will be not longer than 1000000.

Output

Print how many keywords are contained in the description.

Sample Input

1 5 she he say shr her yasherhs

Sample Output

3

Author

Wiskey

Recommend

lcy   |   We have carefully selected several similar problems for you:  3065 2243 2825 3341 3247 

#include<bits/stdc++.h>
using namespace std;
struct Trie
{
  int next[500010][26];
  int fail[500010],end[500010];
  int root,L;
  int newnode(){
        for(int i=0;i<26;i++)
                next[L][i]=-1;
        end[L++]=0;
        return L-1;
  }
  void init(){
      L=0;
      root=newnode();
  }
  void insert(char buf[])
  {
    int len=strlen(buf);
    int now=root;
    for(int i=0;i<len;i++)
    {
        if(next[now][buf[i]-'a']==-1)
           next[now][buf[i]-'a']=newnode();
        now=next[now][buf[i]-'a'];
    }
    end[now]++;
  }
  void build(){
        queue<int>Q;
        fail[root]==root;
        for(int i=0;i<26;i++)
          if(next[root][i]==-1)
              next[root][i]=root;
          else
          {
                fail[next[root][i]]=root;
                Q.push(next[root][i]);
          }
        while(!Q.empty())
        {
          int now=Q.front();
          Q.pop();
          for(int i=0;i<26;i++)
             if(next[now][i]==-1)
                next[now][i]=next[fail[now]][i];
             else
             {
                fail[next[now][i]]=next[fail[now]][i];
                Q.push(next[now][i]);
             }
        }
  }
  int query(char buf[])
  {
    int len=strlen(buf);
    int now=root;
    int res=0;
    for(int i=0;i<len;i++)
    {
        now=next[now][buf[i]-'a'];
        int temp=now;
        while(temp!=root)
        {
          res+=end[temp];
          end[temp]=0;
          temp=fail[temp];
        }
    }
    return res;
  }
};
char buf[1000010];
Trie ac;
int main()
{
  int t;
  int n;
  scanf("%d",&t);
  while(t--)
  {
     scanf("%d",&n);
     ac.init();
     for(int i=0;i<n;i++)
     {
        scanf("%s",buf);
        ac.insert(buf);
     }
     ac.build();
     scanf("%s",buf);
     printf("%d\n",ac.query(buf));
  }
  return 0;
}

AC自動機的模板例題,必須拿下