1. 程式人生 > >PAT (Advanced Level) Practice 1036 Boys vs Girls (25 分)

PAT (Advanced Level) Practice 1036 Boys vs Girls (25 分)

This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N lines of student information. Each line contains a student's name

, gender, ID and grade, separated by a space, where name and ID are strings of no more than 10 characters with no space, gender is either F (female) or M (male), and grade is an integer between 0 and 100. It is guaranteed that all the grades are distinct.

Output Specification:

For each test case, output in 3 lines. The first line gives the name and ID of the female student with the highest grade, and the second line gives that of the male student with the lowest grade. The third line gives the difference grade​F​​−grade​M​​. If one such kind of student is missing, output Absent

in the corresponding line, and output NA in the third line instead.

Sample Input 1:

3
Joe M Math990112 89
Mike M CS991301 100
Mary F EE990830 95

Sample Output 1:

Mary EE990830
Joe Math990112
6

Sample Input 2:

1
Jean M AA980920 60

Sample Output 2:

Absent
Jean AA980920
NA

 根據題目要求將最高的女生和最低的男生找出來, 然後按條件輸出。

程式碼如下:

#include <bits/stdc++.h>
using namespace std;
struct stu
{
	int score;
	char id[15];
	char name[15];
};
int n;
stu f,m;
int feflag=0,mflag=0;
int Minm=0x3f3f3f3f,Maxf=-1;
int main()
{
	scanf("%d",&n);
	for (int i=0;i<n;i++)
	{
		char name[15],id[15],gen[5];
		int score;
		scanf("%s %s %s %d",name,gen,id,&score);
		if(gen[0]=='M')
		{
			mflag=1;
			if(Minm>score)
			{
				Minm=score;
				f.score=score;
				strcpy(m.id,id);
				strcpy(m.name,name);	
			} 
		}
		else
		{
			feflag=1;
			if(Maxf<score)
			{
				Maxf=score;
				m.score=score;
				strcpy(f.id,id);
				strcpy(f.name,name);
			}
		}
	}
	if(feflag)
	{
		printf("%s %s\n",f.name,f.id);
	}
	else 
	{
		printf("Absent\n");
	}
	if(mflag)
	{
		printf("%s %s\n",m.name,m.id);
	}
	else 
	{
		printf("Absent\n");
	}

	if(!feflag||!mflag)
	{
		printf("NA\n");
	}
	else 
	{
		printf("%d\n",Maxf-Minm);
	}
	return 0;
}