1. 程式人生 > >PAT (Advanced Level) Practice 1037 Magic Coupon (25 分)

PAT (Advanced Level) Practice 1037 Magic Coupon (25 分)

The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product... but hey, magically, they have some coupons with negative N's!

For example, given a set of coupons { 1 2 4 −1 }, and a set of product values { 7 6 −2 −3 } (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.

Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

Input Specification:

Each input file contains one test case. For each case, the first line contains the number of coupons N​C​​, followed by a line with N​C​​ coupon integers. Then the next line contains the number of products N​P​​, followed by a line with N​P​​ product values. Here 1≤N​C​​,N​P​​≤10​5​​, and it is guaranteed that all the numbers will not exceed 2​30​​.

Output Specification:

For each test case, simply print in a line the maximum amount of money you can get back.

Sample Input:

4
1 2 4 -1
4
7 6 -2 -3

Sample Output:

43

 排序,先從前往後找,碰到相乘等於或小於0的情況退出,然後記下再從後往前找,遇到之前退出的位置或者相乘等於或小於0的情況退出,然後就能求出答案。

程式碼如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
using namespace std;
const int maxn=1e5+5;
typedef long long ll;
ll a[maxn];
ll b[maxn];
int nc,np;
int compare(ll a,ll b)
{
    return a>b;
}
int main()
{
    scanf("%d",&nc);
    for (int i=0;i<nc;i++)
    {
        scanf("%lld",&a[i]);
    }
    sort(a,a+nc,compare);
    scanf("%d",&np);
    for (int i=0;i<np;i++)
    {
        scanf("%lld",&b[i]);
    }
    sort(b,b+np,compare);
    ll sum=0;
    int loc=0;
    for (;loc<nc&&loc<np;loc++)
    {
        if(a[loc]*b[loc]>0)
            sum+=a[loc]*b[loc];
        else
            break;
    }
    for (int i=nc-1,j=np-1;i>=0&&j>=0&&i>loc&&j>loc;i--,j--)
    {
        if(a[i]*b[j]>0)
            sum+=a[i]*b[j];
        else
            break;
    }
    printf("%lld\n",sum);
    return 0;
}