1. 程式人生 > >5542 The Battle of Chibi (dp+二維樹狀陣列優化)

5542 The Battle of Chibi (dp+二維樹狀陣列優化)

The Battle of Chibi

Time Limit: 6000/4000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others) Total Submission(s): 2882    Accepted Submission(s): 1034Problem Description

Cao Cao made up a big army and was going to invade the whole South China. Yu Zhou was worried about it. He thought the only way to beat Cao Cao is to have a spy in Cao Cao's army. But all generals and soldiers of Cao Cao were loyal, it's impossible to convince any of them to betray Cao Cao. So there is only one way left for Yu Zhou, send someone to fake surrender Cao Cao. Gai Huang was selected for this important mission. However, Cao Cao was not easy to believe others, so Gai Huang must leak some important information to Cao Cao before surrendering. Yu Zhou discussed with Gai Huang and worked out N information to be leaked, in happening order. Each of the information was estimated to has ai value in Cao Cao's opinion. Actually, if you leak information with strict increasing value could accelerate making Cao Cao believe you. So Gai Huang decided to leak exact M information with strict increasing value in happening order. In other words, Gai Huang will not change the order of the N information and just select M of them. Find out how many ways Gai Huang could do this.

Input

The first line of the input gives the number of test cases, T(1≤100). T test cases follow. Each test case begins with two numbers N(1≤N≤103) and M(1≤M≤N), indicating the number of information and number of information Gai Huang will select. Then N numbers in a line, the ith number ai(1≤ai≤109) indicates the value in Cao Cao's opinion of the ith information in happening order.

Output

For each test case, output one line containing Case #x: y, where x is the test case number (starting from 1) and y is the ways Gai Huang can select the information. The result is too large, and you need to output the result mod by 1000000007(109+7).

Sample Input

2 3 2 1 2 3 3 2 3 2 1

Sample Output

Case #1: 3 Case #2: 0

Hint

In the first cases, Gai Huang need to leak 2 information out of 3. He could leak any 2 information as all the information value are in increasing order. In the second cases, Gai Huang has no choice as selecting any 2 information is not in increasing order.

Source

題意:給出n個數,輸出長度為k的嚴格上升子序列的個數

思路:dp[i][j]表示到第i個數字,長度為j的嚴格上升子序列,得到轉移方程為:

dp[i][j] = sum( dp[k][j-1],  a[k] < a[i],  0 <= k < i)

可以用三層for迴圈寫出來,但時間複雜度過大,可以用二維樹狀陣列來優化

#include <bits/stdc++.h>
#define lowbit(i) (i&(-i))
using namespace std;
const int maxn = 1005;
const int mod = 1000000007;
int n;
int a[maxn],dp[maxn][maxn],c[maxn][maxn],b[maxn];
inline int read() {
    int x = 0,f = 1;
    char ch = getchar();
    while(ch<'0' || ch>'9'){if(ch=='-')f=-1;ch = getchar();}
    while(ch>='0'&&ch<='9'){x = x*10+ch-48;ch = getchar();}
    return x*f;
}
inline void update(int j,int x,int num)
{
    while(x <= n) {
        c[j][x] = (c[j][x] + num);
        if(c[j][x] >= mod) c[j][x] %= mod;
        x += lowbit(x);
    }
}
inline int getsum(int j,int x)
{
    int sum = 0;
    while(x > 0) {
        sum = (sum + c[j][x]);
        if(sum >= mod) sum %= mod;
        x -= lowbit(x);
    }
    return sum;
}
int main(void)
{
    int T,m;
    scanf("%d",&T);
    int kase = 0;
    while(T--) {
        kase++;
        scanf("%d %d",&n,&m);
        for(int i = 1; i <= n; i++) {
            a[i] = read();
            b[i] = a[i];
        }
        //離散化
        sort(b + 1,b + 1 + n);
        for(int i = 1; i <= n; i++) {
            a[i] = lower_bound(b + 1,b + 1 + n,a[i]) - b;
        }
        memset(dp,0,sizeof(dp));
        memset(c,0,sizeof(c));
        for(int i = 1; i <= n; i++) {
            for(int j = 1; j <= min(i + 1,m); j++) {
                if(j == 1) dp[i][j] = 1;
                dp[i][j] = (dp[i][j] + getsum(j - 1,a[i] - 1) );
                if(dp[i][j] >= mod) dp[i][j] %= mod;
                update(j,a[i],dp[i][j]);
            }
        }
        int ans = 0;
        for(int i = 1; i <= n; i++) {
            ans = (ans + dp[i][m]);
            if(ans >= mod) ans %= mod;
        }
        printf("Case #%d: ",kase);
        printf("%d\n",ans);
    }
    return 0;
}