1. 程式人生 > >hdu1078 FatMouse and cheese

hdu1078 FatMouse and cheese

題意:每個位置有a[i][j]個乳酪,老鼠從(0,0)位置開始,要求吃的乳酪一次比一次多,老鼠一次最多能走k步,且不走回頭路,問吃到乳酪最多為多少

【思路】跟滑雪很像,重要如何處理k步,見程式碼

FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he's going to enjoy his favorite food.  FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse -- after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole.  Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move. 

Input

There are several test cases. Each test case consists of  a line containing two integers between 1 and 100: n and k  n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) ... (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), ... (1,n-1), and so on.  The input ends with a pair of -1's. 

Output

For each test case output in a line the single integer giving the number of blocks of cheese collected. 

Sample Input

3 1
1 2 5
10 11 6
12 12 7
-1 -1

Sample Output

37
#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
int n,k,dir[4][2]={1,0,-1,0,0,1,0,-1},dp[108][108],s[108][108];
int dfs(int x,int y){
	if(dp[x][y]>0) return dp[x][y];
	int p=0;
	for(int i=0;i<4;++i){
		for(int j=1;j<=k;++j){//k處理,思考
			int dx=x+dir[i][0]*j;
			int dy=y+dir[i][1]*j;
			if(dx>=0&&dx<n&&dy>=0&&dy<n&&s[dx][dy]>s[x][y]){
				p=max(p,dfs(dx,dy)+s[dx][dy]);//該位置取最大值
			}
		}
	}
	return dp[x][y]=p;
}
int main(){
	while(scanf("%d%d",&n,&k)&&(n!=-1&&k!=-1)){
		memset(dp,0,sizeof(dp));
		for(int i=0;i<n;++i)
		for(int j=0;j<n;++j)
		scanf("%d",&s[i][j]);
		printf("%d\n",dfs(0,0)+s[0][0]);//別忘初始位置
	}
}