1. 程式人生 > >A Star not a Tree?(費馬點問題+模擬退火演算法)

A Star not a Tree?(費馬點問題+模擬退火演算法)

A Star not a Tree?

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9377 Accepted: 4043

Description

Luke wants to upgrade his home computer network from 10mbs to 100mbs. His existing network uses 10base2 (coaxial) cables that allow you to connect any number of computers together in a linear arrangement. Luke is particulary proud that he solved a nasty NP-complete problem in order to minimize the total cable length.  Unfortunately, Luke cannot use his existing cabling. The 100mbs system uses 100baseT (twisted pair) cables. Each 100baseT cable connects only two devices: either two network cards or a network card and a hub. (A hub is an electronic device that interconnects several cables.) Luke has a choice: He can buy 2N-2 network cards and connect his N computers together by inserting one or more cards into each computer and connecting them all together. Or he can buy N network cards and a hub and connect each of his N computers to the hub. The first approach would require that Luke configure his operating system to forward network traffic. However, with the installation of Winux 2007.2, Luke discovered that network forwarding no longer worked. He couldn't figure out how to re-enable forwarding, and he had never heard of Prim or Kruskal, so he settled on the second approach: N network cards and a hub.  Luke lives in a loft and so is prepared to run the cables and place the hub anywhere. But he won't move his computers. He wants to minimize the total length of cable he must buy.

Input

The first line of input contains a positive integer N <= 100, the number of computers. N lines follow; each gives the (x,y) coordinates (in mm.) of a computer within the room. All coordinates are integers between 0 and 10,000.

Output

Output consists of one number, the total length of the cable segments, rounded to the nearest mm.

Sample Input

4
0 0
0 10000
10000 10000
10000 0

Sample Output

28284

   題意:給n個點,找出一個點,使這個點到其他所有點的距離之和最小,也就是求費馬點。

#include<cstdio>
#include<algorithm>
#include<cstring>
#include<cmath> 
#include <time.h>
#include<iostream>
using namespace std;

typedef long long ll;

#define INF 1e99
#define N 110
#define eps 1e-8
#define delta 0.98
#define T 100

int n;
int dx[4] = {0, 0, -1, 1};
int dy[4] = {-1, 1, 0, 0};
struct point{
    double x, y;
}p[N];

double dis(point a, point b){
    return sqrt((a.x - b.x) * (a.x - b.x) + (a.y - b.y) * (a.y - b.y));
}
double getsum(point p[], int n, point t){
    double ans = 0.0;
    while(n--) ans += dis(p[n], t);
    return ans;
}

double Search(point p[], int n){
    double ans = INF;
    double t = T;
    point s = p[0];
    while(t > eps){
        bool flag = true;
        while(flag){
            flag = false;
            for(int i=0; i<4; i++){
                point z;
                z.x = s.x + dx[i] * t;
                z.y = s.y + dy[i] * t;
                double tp = getsum(p, n, z);
                if(ans > tp){
                    ans = tp;
                    s = z;
                    flag = true;
                }
            }

        }
        t *= delta;
    }
    return ans;
}

int main(){
    scanf("%d", &n);
    for(int i=0; i<n ;i++)
        scanf("%lf%lf", &p[i].x, &p[i].y);
    printf("%.0lf\n", Search(p, n));
    return 0;
}