1. 程式人生 > >Light oj 1341 Aladdin and the Flying Carpet (唯一分解定理 )

Light oj 1341 Aladdin and the Flying Carpet (唯一分解定理 )

It's said that Aladdin had to solve seven mysteries before getting the Magical Lamp which summons a powerful Genie. Here we are concerned about the first mystery.

Aladdin was about to enter to a magical cave, led by the evil sorcerer who disguised himself as Aladdin's uncle, found a strange magical flying carpet at the entrance. There were some strange creatures guarding the entrance of the cave. Aladdin could run, but he knew that there was a high chance of getting caught. So, he decided to use the magical flying carpet. The carpet was rectangular shaped, but not square shaped. Aladdin took the carpet and with the help of it he passed the entrance.

Now you are given the area of the carpet and the length of the minimum possible side of the carpet, your task is to find how many types of carpets are possible. For example, the area of the carpet 12, and the minimum possible side of the carpet is 2, then there can be two types of carpets and their sides are: {2, 6} and {3, 4}.

Input

Input starts with an integer T (≤ 4000), denoting the number of test cases.

Each case starts with a line containing two integers: a b (1 ≤ b ≤ a ≤ 1012) where a denotes the area of the carpet and b denotes the minimum possible side of the carpet.

Output

For each case, print the case number and the number of possible carpets.

Sample Input

2

10 2

12 2

Sample Output

Case 1: 1

Case 2: 2

先看上面的第一條

#include<bits/stdc++.h>
using namespace std;
int prime[1000055];
vector<int>v;
void init()
{
    memset(prime,0,sizeof(prime));
    prime[0]=1;
    prime[1]=1;
    prime[2]=0;
    int maxm=1000004;
    for(int i=2; i<=maxm; i++)
    {
        if(prime[i]==0)
        {
            for(int j=2;; j++)
            {
                if(i*j<=maxm)
                    prime[i*j]=1;
                else break;
            }
        }
    }
    for(int i=2; i<=maxm; i++)
    {
        if(prime[i]==0)
            v.push_back(i);
    }
    // for(int i=0; i<v.size(); i++)
    //   printf("%d\n",v[i]);
}
long long get_ans(long long a)
{
    long long ans=1;;
    for(int i=0;i<v.size();i++)
    {

        long long  m=0;
        while(!(a%v[i]))
        {
            m++;
            a=a/v[i];
        }
        ans*=(m+1);
        if(v[i]>a)
            break;
        if(a==1)
            break;
    }
    if(a!=1)
        ans*=2;
    return ans;
}
int main()
{
    init();
    int t;
    scanf("%d",&t);
    for(int cas=1; cas<=t; cas++)
    {
       long long x,y,sum,cnt=0;
       cin>>x>>y;
       sum=get_ans(x)/2;
       long long sq=floor(sqrt(x));
       for(int i=1;i<y&&i<=sq;i++)
       {
           if(x%i==0)
            cnt++;
       }
       printf("Case %d: %lld\n",cas,max(sum-cnt,(long long )0));
    }
}