1. 程式人生 > >Game of Connections(hdu 1134,卡特蘭數)

Game of Connections(hdu 1134,卡特蘭數)

Description

This is a small but ancient game. You are supposed to write down the numbers 1, 2, 3, ... , 2n - 1, 2n consecutively in clockwise order on the ground to form a circle, and then, to draw some straight line segments to connect them into number pairs. Every number must be connected to exactly one another. And, no two segments are allowed to intersect.  It's still a simple game, isn't it? But after you've written down the 2n numbers, can you tell me in how many different ways can you connect the numbers into pairs? Life is harder, right? 

Input

Each line of the input file will be a single positive number n, except the last line, which is a number -1. You may assume that 1 <= n <= 100. 

Output

For each n, print in a single line the number of ways to connect the 2n numbers into pairs. 

Sample Input

2 3 -1

Sample Output

2 5

題解:

很明顯,卡特蘭數,H【n】 = H【n-1】*(4*n-2)/(n+1){n>=2};

程式碼如下:

import java.math.*;
import java.util.*;

public class Main
{
    public static void main(String[] args)
    {
        Scanner cin =new Scanner(System.in);
        while(cin.hasNext())
        {
            int n=cin.nextInt();
            if(n==-1)
                break;
            BigInteger big = new BigInteger("1");
            for(int i=2; i<=n; i++)
            {
                big=big.multiply(new BigInteger(String.format("%d",4*i-2))).
                     divide(new BigInteger(String.format("%d",i+1)));
            }
            System.out.println(big);
        }
    }
}