1. 程式人生 > >【題解】UVA 1585

【題解】UVA 1585

題目描述

There is an objective test result such as “OOXXOXXOOO”. An ‘O’ means a correct answer of a problem and an ‘X’ means a wrong answer. The score of each problem of this test is calculated by itself and its just previous consecutive ‘O’s only when the answer is correct. For example, the score of the 10th problem is 3 that is obtained by itself and its two previous consecutive ‘O’s. Therefore, the score of “OOXXOXXOOO” is 10 which is calculated by “1+2+0+0+1+0+0+1+2+3”. You are to write a program calculating the scores of test results.

Input

Your program is to read from standard input. The input consists of T test cases. The number of test cases T is given in the first line of the input. Each test case starts with a line containing a string composed by ‘O’ and ‘X’ and the length of the string is more than 0 and less than 80. There is no spaces between ‘O’ and ‘X’.

Output

Your program is to write to standard output. Print exactly one line for each test case. The line is to contain the score of the test case.

Sample Input

5

OOXXOXXOOO

OOXXOOXXOO

OXOXOXOXOXOXOX

OOOOOOOOOO

OOOOXOOOOXOOOOX

Sample Output

10

9

7

55

30

題意分析

題意: 遇到 X 就停止連擊,否則則加上連擊分數(例如:連續的OO 則是 1 + 2)。問給你這個串的分數結果是多少。

AC程式碼

/**
* Copyright(c)
* All rights reserved.
* Author : M
* Date : 2018-10-17-16.33.57
* Description : sample
*/
#include <cstdio>
#include <cmath>
#include <iostream>
#include <algorithm>
#include <iomanip>
#include <cstdlib>
#include <map>
#include <list>
#include <stack>
#include <queue>
#include <string>
#include <cstring>
#include <memory.h>
#define MAXN 10005
#define INF 0x3f3f3f3f
using namespace std;
typedef long long ll;

int main()
{
    int t,sum,combe;
    bool z;
    string s;
    cin>>t;
    while(t--)
    {
        cin>>s;
        z = true;
        sum = 0;combe =0;
        for(int i=0;i<s.size();i++)
        {
            if(s[i] == 'O')
            {
                if(z) {combe++;}
                sum += combe;
            }
            else
            {
                combe = 0;
            }
        }
        cout<<sum<<endl;
    }
    return 0;
}