1. 程式人生 > >PAT-A 1154 Vertex Coloring

PAT-A 1154 Vertex Coloring

proper vertex coloring is a labeling of the graph's vertices with colors such that no two vertices sharing the same edge have the same color. A coloring using at most k colors is called a (proper) k-coloring.

Now you are supposed to tell if a given coloring is a proper k-coloring.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N and M(both no more than 10​4​​), being the total numbers of vertices and edges, respectively. Then M lines follow, each describes an edge by giving the indices (from 0 to N−1) of the two ends of the edge.

After the graph, a positive integer K (≤ 100) is given, which is the number of colorings you are supposed to check. Then K lines follow, each contains N colors which are represented by non-negative integers in the range of int. The i-th color is the color of the i-th vertex.

Output Specification:

For each coloring, print in a line k-coloring if it is a proper k-coloring for some positive k, or No if not.

Sample Input:

10 11

8 7

6 8

4 5

8 4

8 1

1 2

9 8

9 1

1 0

2 4

4

0 1 0 1 4 1 0 1 3 0

0 1 0 1 4 1 0 1 0 0

8 1 0 1 4 1 0 5 3 0

1 2 3 4 5 6 7 8 8 9

Sample Output:

4-coloring

No

6-coloring

No

題意:

給出圖的節點和邊,要求任意相連節點顏色不同,給出塗色方案,判斷方案是否滿足要求,如果滿足要求就輸出n-coloring,其中n是顏色的種數,如果不滿足條件則輸出No

Code:

#include <stdio.h>
#include <set>
using namespace std;

int main(){
    int n, m;
    scanf("%d %d", &n, &m);
    int path[m][2];
    for(int i = 0; i < m; i++)
        scanf("%d %d", &path[i][0], &path[i][1]);
    int k;
    scanf("%d", &k);
    for(int i = 0; i < k; i++){
        int color[n];
        set<int> c;
        for(int j = 0; j < n; j++){
            scanf("%d", &color[j]);
            c.insert(color[j]);
        }
        int j = 0;
        for(; j < m; j++){
            if(color[path[j][0]] == color[path[j][1]]){
                break;
            }
        }
        if(j == m) printf("%d-coloring\n", c.size());
        else printf("No\n");
    }
    return 0;
}