1. 程式人生 > >HDU 1022 Train Problem I 棧的應用

HDU 1022 Train Problem I 棧的應用

Train Problem I

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 48177    Accepted Submission(s): 18184

Problem Description

As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world ^v^). But here comes a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can't leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the trains can get out in an order O2.

Input

The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample Input.

Output

The output contains a string "No." if you can't exchange O2 to O1, or you should output a line contains "Yes.", and then output your way in exchanging the order(you should output "in" for a train getting into the railway, and "out" for a train getting out of the railway). Print a line contains "FINISH" after each test case. More details in the Sample Output.

Sample Input

3 123 321

3 123 312

Sample Output

Yes.

in

in

in

out

out

out

FINISH

No.

FINISH

Hint

Hint

For the first Sample Input, we let train 1 get in, then train 2 and train 3.

So now train 3 is at the top of the railway, so train 3 can leave first, then train 2 and train 1.

In the second Sample input, we should let train 3 leave first, so we have to let train 1 get in, then train 2 and train 3.

Now we can let train 3 leave.

But after that we can't let train 1 leave before train 2, because train 2 is at the top of the railway at the moment.

So we output "No.".

Author

Ignatius.L

Recommend

We have carefully selected several similar problems for you:  1026 1023 1004 1020 1032 

演算法分析:

題意:

給你n個數,n<=9,兩個序列a和b,一個棧,問b是否是a的出棧順序,不是輸出”NO”,是輸出入棧和出棧步驟

例子:

1234    2314

可以進1 進2 出2 進3 出3 出1 進4 出4

分析:

       來自:https://blog.csdn.net/u013480600/article/details/19210519

      首先如果出棧序列可行,那麼必定存在唯一的可行出棧方式(想想是不是)。我們只需要一步步嘗試出棧和入棧操作是否滿足當前的出棧序列中的元素順序即可(每步的嘗試不是 出棧操作 就是 入棧操作 其實很簡單了,且只有出棧不可行的時候,我們才去入棧)。

        我們只要用兩個指標i和j,指向當前需要處理的入棧和出棧的那個字元即可。

        先看如果我們把棧S中的元素出棧,如果S出棧的元素正好是j所指的元素,那麼就出棧且j++處理下一個i和j對即可。

        如果出棧不可行,那麼我們就把i所指元素入棧即可。

        注意出棧和入棧需要滿足下面條件:

        出棧:棧S不能為空  且  j不能超過出棧序列的最後一個元素 且 S.top() == b【j】所指元素

        入棧:i不能超過入棧序列的最後一個元素

程式碼實現:

#include <bits\stdc++.h>
using namespace std;
#define N 1100
typedef long long ll;
int n;
string a,b;
vector<string>res;
bool ju()
{
    int i=0,j=0;
    stack<int>s;
    while(i<n||j<n)
    {
        if(!s.empty()&&s.top()==b[j]&&j<n)//出棧
        {
            s.pop();
           res.push_back("out");
           j++;
        }
        else   ///出棧
        {
          if(i==n)
          {
            return 0;
          }
          res.push_back("in");
          s.push(a[i]);
          i++;
        }
    }
    return 1;

}
int main()
{
    while(scanf("%d",&n)!=-1)
    {
        res.clear();
        cin>>a>>b;
        if(!ju())
            cout<<"No."<<endl;
        else
        {
            cout<<"Yes."<<endl;
            for(int i=0;i<res.size();i++)
                cout<<res[i]<<endl;
        }
        cout<<"FINISH"<<endl;
    }
    return 0;
}