1. 程式人生 > >Fence Repair POJ

Fence Repair POJ

Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li

). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.

Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of the N

-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the Nplanks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

Input

Line 1: One integer N, the number of planks  Lines 2.. N+1: Each line contains a single integer describing the length of a needed plank

Output

Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts

Sample Input

3 8 5 8

Sample Output

34                                                                                                                                                                                                     

Hint

He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8.  The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into 16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).

題意:

要將一塊木板分成n塊,然後給出了每塊的長度,切割都要有花費,每次切割的花費就是切割的木板的長度,要求最小的花費。

錯誤思路:

我以為每次只要把所需要的最長的先切去所花費用就最短,這種想法是錯的。並不是最小的花費。因為我們每次切出來的兩塊不一定就是我們直接就需要的,一般是需要繼續切,才能得到我們需要的。

wrong程式碼wrong程式碼:

#include<iostream>         
#include<algorithm>
using namespace std;
int main()
{
    int a[20010];
    int n,ans,sum;
    while(cin>>n)
    {
        for(int i=0;i<n;++i)
        {
            cin>>a[i];
            sum+=a[i];
        }
        sort(a,a+n);
        for(i=n-1;i>0;--i)
        {
            ans+=sum;
            sum-=a[i];
        }
        cout<<ans<<endl;
    }
    return 0;
}

正確的思路:

要花費最少,那麼就希望每次所切割的木板都是最短的,所以就可以反過來想,從切割後的n塊木板每次找兩塊最短的合併。用優先佇列來寫十分方便。

程式碼:

#include<iostream>
#include<cstdio>
#include<queue>
#include<cstring>
#include<cmath>
#include<algorithm> 
using namespace std;
int main()
{
    long long n,l,sum=0;
	scanf("%lld",&n);
	priority_queue<int, vector<int>, greater<int> > q; //定義優先佇列q,每次取出的都是最小的
	for(int i=0;i<n;i++)
	{
		scanf("%lld",&l);
		q.push(l); //入隊
	}
	
	while(q.size()>1)
	{
		long long l1,l2;   //從佇列中取出最短的兩個長度
		l1=q.top();   
		q.pop();
		l2=q.top();
		q.pop();
		
		sum+=l1+l2;
		q.push(l1+l2);  //將合併的長度入隊
		
	}
	printf("%lld\n",sum); 
	return 0;
}