1. 程式人生 > >【PAT甲級】1004 Counting Leaves (30 分)

【PAT甲級】1004 Counting Leaves (30 分)

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.

Output Specification:

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01

 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:

2 1
01 1 02

Sample Output:

0 1

【翻譯】:輸入N,M,分別代表樹的節點數和非葉子節點總數,接下來的M行輸入非葉子節點ID(兩位數),k,孩子數,ID[1]......ID[k],孩子節點的ID,輸入以0結尾,輸出從根節點開始每一層孩子節點數,資料間有空格,行尾沒有空格。

又是參考柳神的,確實很easy,就是用dfs,首先用vector構建數,然後用深搜搜每一層就好了。 

#include <iostream>
#include <algorithm>
#include <vector>
#define MAX 1000
using namespace std;
int ans[MAX];
int maxdep = -1;
vector<int> v[MAX];
void dfs(int index,int depth){
	if(v[index].size() == 0){
		ans[depth]++;
		maxdep = max(depth, maxdep);
		return;
	}
	for(int i = 0; i < v[index].size(); i++){
		dfs(v[index][i], depth + 1);
	}
}
int main(){
	int n,m,k,c,id;//n是樹的節點數,m樹中無葉子節點的節點數 
	cin>>n>>m;
	for(int i = 0; i < m; i++){
		cin>>id>>k;
		for(int j = 0; j < k; j++){
			cin>>c;
			v[id].push_back(c);
		}
	}
	dfs(1,0);
	cout<<ans[0];
	for(int i = 1; i <= maxdep; i++){
		cout<<" "<<ans[i];
	}	
	return 0;
}