1. 程式人生 > >1671 Phone List (字典樹模板)

1671 Phone List (字典樹模板)

Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers: 1. Emergency 911 2. Alice 97 625 999 3. Bob 91 12 54 26 In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.

Input

The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.

Output

For each test case, output “YES” if the list is consistent, or “NO” otherwise.

Sample Input

2
3
911
97625999
91125426
5
113
12340
123440
12345
98346

Sample Output

NO
YES

字典樹 模板   與 HDU 1251 統計難題 類似  點選開啟連結

注意 區域性變數定義結構體的時候,內部整數變數不為0

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm> 
using namespace std;
struct node
{
	node *nex[10];
	int sum;	
}*head;
int flag;
void init()
{
	head=new node;
	for(int i=0;i<10;i++)
		head->nex[i]=NULL;
}
void insert(char str[])
{
	int id;
	int len=strlen(str);
	node *p=head;
	for(int i=0;i<len;i++)
	{
		id=str[i]-'0';
		if(p->nex[id]==NULL)
		{
			p->nex[id]=new node;
			p=p->nex[id];
			p->sum=0; // 坑死
			for(int j=0;j<10;j++)
				p->nex[j]=NULL; 
		}
		else
		{
			p=p->nex[id];
			if(p->sum==1)
			{
				flag=1;
				return;				
			}
		}
	}
	p->sum=1;
	for(int i=0;i<10;i++)
	{
		if(p->nex[i]!=NULL)
		{
			flag=1;
			return;
		}
	}
}
void dealnode(node *p)
{
	for(int i=0;i<10;i++)
		if(p->nex[i]!=NULL)
		{
			dealnode(p->nex[i]);
		}
	free(p);
}
int main()
{
	int len,n;
	char str[15];
	int T;
	scanf("%d",&T);
	while(T--)
	{
		init();
		scanf("%d",&n);
		flag=0;
		while(n--)
		{
			scanf("%s",str);
			insert(str);
		}
		if(flag) printf("NO\n");
		else printf("YES\n");
		dealnode(head);
	}
	
	return 0;
}