1. 程式人生 > >2420 A Star not a Tree? 三分套三分 或 模擬退火

2420 A Star not a Tree? 三分套三分 或 模擬退火

Luke wants to upgrade his home computer network from 10mbs to 100mbs. His existing network uses 10base2 (coaxial) cables that allow you to connect any number of computers together in a linear arrangement. Luke is particulary proud that he solved a nasty NP-complete problem in order to minimize the total cable length.  Unfortunately, Luke cannot use his existing cabling. The 100mbs system uses 100baseT (twisted pair) cables. Each 100baseT cable connects only two devices: either two network cards or a network card and a hub. (A hub is an electronic device that interconnects several cables.) Luke has a choice: He can buy 2N-2 network cards and connect his N computers together by inserting one or more cards into each computer and connecting them all together. Or he can buy N network cards and a hub and connect each of his N computers to the hub. The first approach would require that Luke configure his operating system to forward network traffic. However, with the installation of Winux 2007.2, Luke discovered that network forwarding no longer worked. He couldn't figure out how to re-enable forwarding, and he had never heard of Prim or Kruskal, so he settled on the second approach: N network cards and a hub. Luke lives in a loft and so is prepared to run the cables and place the hub anywhere. But he won't move his computers. He wants to minimize the total length of cable he must buy.

Input

The first line of input contains a positive integer N <= 100, the number of computers. N lines follow; each gives the (x,y) coordinates (in mm.) of a computer within the room. All coordinates are integers between 0 and 10,000.

Output

Output consists of one number, the total length of the cable segments, rounded to the nearest mm.

Sample Input

4
0 0
0 10000
10000 10000
10000 0

Sample Output

28284

題解:經過分析,發現若x固定的情況下,存在二次函式性質,所以我們可以三分套三分來解決

第二種,他是一個尋找最優解的情況,因此也可用模擬退火來解決

三分套三分:

#include<iostream>
#include<cstdio>
#include<cmath>
using namespace std;
#define eps 1e-8
struct node{
	double x,y;
}a[110];
int n;
double judge_(double x,double y)
{
	double ans=0;
	for(int i=1;i<=n;i++)
		ans+=sqrt((x-a[i].x)*(x-a[i].x)+(y-a[i].y)*(y-a[i].y));
	return ans;
} 
double judge(double x)
{
	double l=0,r=10000;
	double ans;
	while((r-l)>eps)
	{
		double m1=l+(r-l)/3;
		double m2=r-(r-l)/3;
		double s1=judge_(x,m1);
		double s2=judge_(x,m2); 
		if(s1<s2)
			r=m2,ans=s1;
		else
			l=m1,ans=s2;
	}
	return ans;
}
int main()
{
	while(~scanf("%d",&n))
	{
		for(int i=1;i<=n;i++)scanf("%lf%lf",&a[i].x,&a[i].y);
		double l=0,r=10000;
		double ans;
		while((r-l)>eps)
		{
			double m1=l+(r-l)/3;
			double m2=r-(r-l)/3;
			double s1=judge(m1);
			double s2=judge(m2); 
			if(s1<s2)
				r=m2,ans=s1;
			else
				l=m1,ans=s2;
		}
		printf("%.0f\n",(ans));
	}
	return 0;
} 

模擬退火:

#include<iostream>
#include<cstdio>
#include<cmath>
using namespace std;
#define eps 1e-10
struct node{
	double x,y;
}a[110];
int n;
double judge_(double x,double y)
{
	double ans=0;
	for(int i=1;i<=n;i++)
		ans+=sqrt((x-a[i].x)*(x-a[i].x)+(y-a[i].y)*(y-a[i].y));
	return ans;
}
int fx[5]={0,0,1,-1};
int fy[5]={1,-1,0,0};
int main()
{
	while(~scanf("%d",&n))
	{
		for(int i=1;i<=n;i++)scanf("%lf%lf",&a[i].x,&a[i].y);
		double l=0,r=10000;
		double ans,x=0,y=0,t=1,xx,yy;
		while(t>eps)
		{
			ans=judge_(x,y);
			int i;
			for(i=0;i<4;i++)
			{
				xx=x+t*fx[i];
				yy=y+t*fy[i];
				if(judge_(xx,yy)+eps<ans)
					break;
			}
			if(i!=4)
				x=xx,y=yy;
			else
				t*=0.88;
		}
		printf("%.0f\n",(ans));
	}
	return 0;
}