1. 程式人生 > >POJ-2251 Dungeon Master(BFS)

POJ-2251 Dungeon Master(BFS)

                                                     Dungeon Master

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 50464 Accepted: 18983

Description

You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides. 

Is an escape possible? If yes, how long will it take? 

Input

The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size). 
L is the number of levels making up the dungeon. 
R and C are the number of rows and columns making up the plan of each level. 
Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a '#' and empty cells are represented by a '.'. Your starting position is indicated by 'S' and the exit by the letter 'E'. There's a single blank line after each level. Input is terminated by three zeroes for L, R and C.

Output

Each maze generates one line of output. If it is possible to reach the exit, print a line of the form 

Escaped in x minute(s).


where x is replaced by the shortest time it takes to escape. 
If it is not possible to escape, print the line 

Trapped!

Sample Input

3 4 5
S....
.###.
.##..
###.#

#####
#####
##.##
##...

#####
#####
#.###
####E

1 3 3
S##
#E#
###

0 0 0

Sample Output

Escaped in 11 minute(s).
Trapped!

題意:

給你一個三維的矩陣,有開始點,有結束點,每次可以走東、西、南、北、上、下。

其中有些點為石頭,不能通過,現在求從開始點走到結束點的最短時間。如果不能走到則輸出"Trapped!"。

思路:

一開始用的DFS,超時了。改成BFS就好了,直接套模板即可。。。

程式碼:

#include<cstdio>
#include<iostream>
#include<cstring>
#include<queue>
using namespace std;
const int MAXN = 32;

char maze[MAXN][MAXN][MAXN];
bool book[MAXN][MAXN][MAXN];
int x2, y2, z2;
int move[6][3] = { {0,0,1}, {0,1,0}, {0,-1,0}, {0,0,-1}, {1,0,0}, {-1,0,0}};
int Min, L, R, C;;
struct State
{
	int x, y, z;
	int Step;
};
bool check(State s)
{
	if(s.x >= L || s.x < 0 || s.y >= R || s.y < 0 || s.z >= C || s.z < 0)
		return 0;
	if(book[s.x][s.y][s.z] == false && maze[s.x][s.y][s.z] != '#') {
		return 1;
	}
	return 0;
}
void bfs(State s)
{
	queue <State> q;
	State now, next;
	q.push(s);
	book[s.x][s.y][s.z] = true;
	while(!q.empty())
	{
		now = q.front();
		if(now.x == x2 && now.y == y2 && now.z == z2){
			Min = now.Step;
			return ;
		}
		for(int i = 0; i < 6; i++) {
			next.x = now.x + move[i][0];
			next.y = now.y + move[i][1];
			next.z = now.z + move[i][2];
			if(check(next)) {
				next.Step = now.Step + 1;
				q.push(next);
				book[next.x][next.y][next.z] = true;
			}
		}
		q.pop();
	}
	return ;
	
}
int main()
{
	
	while(scanf("%d%d%d", &L, &R, &C)!=EOF)
	{
		if(L == 0 && R == 0 && C == 0)
			break;
		memset(book, false, sizeof(book));
		int x1, y1, z1;
		for(int i = 0; i < L; i++) 
			for(int j = 0; j < R; j++) {
				scanf("%s", maze[i][j]);
				for(int k = 0; k < C; k++) {
					if(maze[i][j][k] == 'S') {
						x1 = i;y1 = j; z1 = k;
					}
					if(maze[i][j][k] == 'E') {
						x2 = i; y2 = j; z2 = k;
					}
				} 
					
			}
				
		State s;
		s.x = x1; s.y = y1; s.z = z1; s.Step = 0;
			
		Min = 9999999;
		bfs(s);
		if(Min == 9999999)	
			printf("Trapped!\n");
		else
			printf("Escaped in %d minute(s).\n", Min);		
	
	} 
	
	return 0;
}