1. 程式人生 > >PAT 甲級 1043 Is It a Binary Search Tree(二叉搜尋樹)

PAT 甲級 1043 Is It a Binary Search Tree(二叉搜尋樹)

1043 Is It a Binary Search Tree (25 分)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.

Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in a line YES

if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or NO if not. Then if the answer is YES, print in the next line the postorder traversal sequence of that tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

7
8 6 5 7 10 8 11

Sample Output 1:

YES
5 7 6 8 11 10 8

Sample Input 2:

7
8 10 11 8 6 7 5

Sample Output 2:

YES
11 8 10 7 5 6 8

Sample Input 3:

7
8 6 8 5 10 9 11

Sample Output 3:

NO

 Analysis:

judge twice whether it is bst or the mirror one,the algorithms are similar. The algorithm is excellent and deserve your memorizing .

#include<stdio.h>
#include<iostream>
#include<string>
#include<vector>
#include<map>
#include<queue>
#include<set>
#include<math.h>
#include<string.h>
#include<algorithm>
using namespace std;
int pre[1000],post[1000],num; 
bool flag;
void judge(int l,int r)
{
	if(l>r)return;
	int i=l+1,j=r;
	if(flag==false){
		while(i<=r&&pre[i]<pre[l])i++;//properties of the preorder traserval of bst
		while(j>l&&pre[j]>=pre[l])j--;
	}
	else{//if the mirror ,the right subtree nodes are smaller than the root,while the left ones are not .
		while(i<=r&&pre[i]>=pre[l])i++;
		while(j>l&&pre[j]<pre[l])j--;
	}
	if(i-j!=1)return ;//if is bst 
	judge(l+1,j);//recursion to locate the node, postorder traserval 
	judge(i,r);
	post[num++]=pre[l];
}
int main()
{
	//freopen(".txt","r",stdin);
	int n;
	cin>>n;
	for(int i=0;i<n;i++)
		 cin>>pre[i];
	judge(0,n-1);
	if(num!=n){
		num=0;
		flag=true;
		judge(0,n-1);
	}
	if(num!=n){
		printf("NO\n");
	}else{
		printf("YES\n%d",post[0]);
		for(int i=1;i<n;i++)
			printf(" %d",post[i]);
	}
	return 0;
}