1. 程式人生 > >PAT (Advanced Level) Practice 1004 Counting Leaves (30 分)

PAT (Advanced Level) Practice 1004 Counting Leaves (30 分)

1004 Counting Leaves (30 分)

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.

Output Specification:

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01

 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:

2 1
01 1 02

Sample Output:

0 1

題目大意:給出節點總數和非葉節點總數,求每一層的葉節點個數。

題解1:

思路:

每個節點用一個struct node記錄,node中使用vector<int>child記錄它的子節點。(這題建樹比較簡單)

深度優先搜尋DFS,從根節點01開始,記錄每個節點的層數,遇到葉節點後,該層葉節點總數加1,同時記錄最大層數。

最後輸出所有層數的葉節點個數。

原始碼1:

#include<iostream>
#include<stdlib.h>
#include<vector>
using namespace std;
int n, m, i, j, k, temp,maxlevel=0;
int level[100] = { 0 };
struct node
{
	vector<int>child;
};
vector<node>v;
void dfs(int r, int step)
{
	int i;
	if (v[r].child.size()==0)
	{
		level[step]++;
		if (step > maxlevel)maxlevel = step;
		return;
	}
	for (i = 0; i < v[r].child.size(); i++)
	{
		dfs(v[r].child[i], step + 1);
	}
	return;
}
int main()
{
	scanf("%d %d", &n, &m);
	v.resize(n + 1);
	for (i = 1; i <= m; i++)
	{
		scanf("%d %d", &temp,&k);
		v[temp].child.resize(k);
		for (j = 0; j < k; j++)
			scanf("%d", &v[temp].child[j]);	
	}
	dfs(01, 0);
	for (i = 0; i <= maxlevel; i++)
		if (i == 0)printf("%d", level[i]);
		else printf(" %d", level[i]);
	system("pause");
	return 0;
}