1. 程式人生 > >POJ 1269 Intersecting Lines(計算幾何)

POJ 1269 Intersecting Lines(計算幾何)

Description:

We all know that a pair of distinct points on a plane defines a line and that a pair of lines on a plane will intersect in one of three ways: 1) no intersection because they are parallel, 2) intersect in a line because they are on top of one another (i.e. they are the same line), 3) intersect in a point. In this problem you will use your algebraic knowledge to create a program that determines how and where two lines intersect. Your program will repeatedly read in four points that define two lines in the x-y plane and determine how and where the lines intersect. All numbers required by this problem will be reasonable, say between -1000 and 1000.

Input:

The first line contains an integer N between 1 and 10 describing how many pairs of lines are represented. The next N lines will each contain eight integers. These integers represent the coordinates of four points on the plane in the order x1y1x2y2x3y3x4y4. Thus each of these input lines represents two lines on the plane: the line through (x1,y1) and (x2,y2) and the line through (x3,y3) and (x4,y4). The point (x1,y1) is always distinct from (x2,y2). Likewise with (x3,y3) and (x4,y4).

Output:

There should be N+2 lines of output. The first line of output should read INTERSECTING LINES OUTPUT. There will then be one line of output for each pair of planar lines represented by a line of input, describing how the lines intersect: none, line, or point. If the intersection is a point then your program should output the x and y coordinates of the point, correct to two decimal places. The final line of output should read “END OF OUTPUT”.

Sample Input:

5 0 0 4 4 0 4 4 0 5 0 7 6 1 0 2 3 5 0 7 6 3 -6 4 -3 2 0 2 27 1 5 18 5 0 3 4 0 1 2 2 5

Sample Output:

INTERSECTING LINES OUTPUT POINT 2.00 2.00 NONE LINE POINT 2.00 5.00 POINT 1.07 2.20 END OF OUTPUT

題目連結

判斷兩直線關係(重合、平行、相交(求交點))。

G++"%.2lf"會WA,要用"%.2f"

AC程式碼:

#include <iostream>
#include <cstdio>
#include <cmath>
using namespace std;

const int maxn = 1e1 + 5;
const double eps = 1e-8;

struct Point {
	double X, Y;

	void Input() {
		scanf("%lf%lf", &X, &Y);
	}

	Point operator - (const Point &B) const {
		return Point {X - B.X, Y - B.Y};
	}

	double operator * (const Point &B) const {
		return X * B.X + Y * B.Y;
	}

	double operator ^ (const Point &B) const {
		return X * B.Y - Y * B.X;
	}
};

struct Segment {
	Point S, T;
	
	void Input() {
		S.Input();
		T.Input();
	}

	double operator ^ (const Segment &B) const {
		return (T - S) ^ (B.T - B.S);
	}
};

int N;

bool Parallel(Segment A, Segment B) {
	return fabs((A.T - A.S) ^ (B.T - B.S)) <= eps;
}

bool IsIntersect(Segment A, Segment B) {
	return fabs((B.S - A.S) ^ (B.T - A.S)) <= eps;
}

Point IntersectionPoint(Segment A, Segment B) {
	double X = (B.T - B.S) ^ (A.S - B.S), Y = (B.T - B.S) ^ (A.T - B.S);
	return Point {(A.S.X * Y - A.T.X * X) / (Y - X), (A.S.Y * Y - A.T.Y * X) / (Y - X)};
}

int main(int argc, char *argv[]) {
	scanf("%d", &N);
	printf("INTERSECTING LINES OUTPUT\n");
	for (int i = 0; i < N; ++i) {
		Segment A, B;
		A.Input();
		B.Input();
		if (Parallel(A, B)) {
			if (IsIntersect(A, B)) {
				printf("LINE\n");
			}
			else {
				printf("NONE\n");
			}
		}
		else {
			Point P = IntersectionPoint(A, B);
			printf("POINT %.2f %.2f\n", P.X, P.Y);
		}
	}
	printf("END OF OUTPUT\n");
	return 0;
}