1. 程式人生 > >【PAT甲級】1092 To Buy or Not to Buy

【PAT甲級】1092 To Buy or Not to Buy

Eva would like to make a string of beads with her favorite colors so she went to a small shop to buy some beads. There were many colorful strings of beads. However the owner of the shop would only sell the strings in whole pieces. Hence Eva must check whether a string in the shop contains all the beads she needs. She now comes to you for help: if the answer is Yes

, please tell her the number of extra beads she has to buy; or if the answer is No, please tell her the number of beads missing from the string.

For the sake of simplicity, let's use the characters in the ranges [0-9], [a-z], and [A-Z] to represent the colors. For example, the 3rd string in Figure 1 is the one that Eva would like to make. Then the 1st string is okay since it contains all the necessary beads with 8 extra ones; yet the 2nd one is not since there is no black bead and one less red bead.

figbuy.jpg

Figure 1

Input Specification:

Each input file contains one test case. Each case gives in two lines the strings of no more than 1000 beads which belong to the shop owner and Eva, respectively.

Output Specification:

For each test case, print your answer in one line. If the answer is Yes, then also output the number of extra beads Eva has to buy; or if the answer is No

, then also output the number of beads missing from the string. There must be exactly 1 space between the answer and the number.

Sample Input 1:

ppRYYGrrYBR2258
YrR8RrY

Sample Output 1:

Yes 8

Sample Input 2:

ppRYYGrrYB225
YrR8RrY

Sample Output 2:

No 2

題目大意

這題就是給出兩串珠子,第一串是賣的珠子,第二串是我需要的珠子,如果賣的珠子夠,則輸出多餘了多少珠子;如果賣的珠子不夠,則輸出還差多少珠子。

個人思路

這題是乙級的1039,也是雜湊演算法的應用。

設立一個計數陣列,對映所有ascii碼的字元的計數。然後逐個比較看是多了還是少了,再計算出來即可。

程式碼實現

#include <cstdio>
#include <cstring>
#include <string>
#include <cmath>
#include <algorithm>
#include <iostream>
#define ll long long

const int maxn = 200;

using namespace std;

int main() {
    // 初始化
    int want[maxn] = {0}, sale[maxn] = {0};
    int duo = 0, shao = 0;
    string salelist, wantlist;
    // 輸入並記錄
    cin >> salelist >> wantlist;
    int salelen = int(salelist.length()), wantlen = int(wantlist.length());
    for (int i = 0; i < salelen; i ++) {
        sale[salelist.at(i)] ++;
    }
    for (int i = 0; i < wantlen; i ++) {
        want[wantlist.at(i)] ++;
    }
    // 判斷是否足夠,如果不夠計算少了多少
    bool isok = true;
    for (int i = 0; i < maxn; i ++) {
        if (want[i] == 0)
            continue;
        if (want[i] > sale[i]) {
            isok = false;
            shao += want[i] - sale[i];
        }
    }
    // 如果足夠足夠計算多了多少並輸出
    if (isok) {
        for (int i = 0; i < maxn; i ++) {
            if (sale[i] == 0)
                continue;
            if (sale[i] > want[i]) {
                duo += sale[i] - want[i];
            }
        }
        cout << "Yes " << duo;
    }
    else {
        cout << "No " << shao;
    }
    
    return 0;
}

總結

學習不息,繼續加油