1. 程式人生 > >POJ1308 Is It A Tree?【並查集】

POJ1308 Is It A Tree?【並查集】

Is It A Tree?

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 39918 Accepted: 13143

Description

A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties.  There is exactly one node, called the root, to which no directed edges point.  Every node except the root has exactly one edge pointing to it.  There is a unique sequence of directed edges from the root to each node.  For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not. 

In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

Input

The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.

Output

For each test case display the line "Case k is a tree." or the line "Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).

Sample Input

6 8  5 3  5 2  6 4
5 6  0 0

8 1  7 3  6 2  8 9  7 5
7 4  7 8  7 6  0 0

3 8  6 8  6 4
5 3  5 6  5 2  0 0
-1 -1

Sample Output

Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.

Source

問題描述:給出有向邊的描述,問結點是否構成樹。不存在環,且都連通使用並查集。注意:沒有結點也為樹。

AC的C++程式:

#include<iostream>
#include<set>

using namespace std;

const int N=100010;
int pre[N];
set<int>s;

void init()
{
	for(int i=0;i<N;i++)
	  pre[i]=i;
}

int find(int x)
{
	if(x!=pre[x])
	  pre[x]=find(pre[x]);
	return pre[x];
}

bool join(int x,int y)
{
	int fx=find(x);
	int fy=find(y);
	if(fx!=fy){
		pre[fx]=fy;
		return false;
	}
	return true;
}

int main()
{
	int a,b,t=0;
	while(scanf("%d%d",&a,&b)){
		if(a==-1&&b==-1)
		  break;
		if(a==0||b==0){
			printf("Case %d is a tree.\n",++t);
			continue;
		}
		init();
		s.clear(); 
		int k=0;
		bool flag=true;
		while(a||b){
			s.insert(a);
			s.insert(b);
			k++;//邊數 
			if(join(a,b))
			  flag=false;//存在環了 
			scanf("%d%d",&a,&b);
		}
		if(flag&&k==s.size()-1)//不存在環,且都連通 
		  printf("Case %d is a tree.\n",++t);
		else
		  printf("Case %d is not a tree.\n",++t);
	}
	return 0;
}