1. 程式人生 > >POJ1789 Truck History【最小生成樹】

POJ1789 Truck History【最小生成樹】

Truck History

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 34225 Accepted: 13241

Description

Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vegetable delivery, other for furniture, or for bricks. The company has its own code describing each type of a truck. The code is simply a string of exactly seven lowercase letters (each letter on each position has a very special meaning but that is unimportant for this task). At the beginning of company's history, just a single truck type was used but later other types were derived from it, then from the new types another types were derived, and so on.  Today, ACM is rich enough to pay historians to study its history. One thing historians tried to find out is so called derivation plan -- i.e. how the truck types were derived. They defined the distance of truck types as the number of positions with different letters in truck type codes. They also assumed that each truck type was derived from exactly one other truck type (except for the first truck type which was not derived from any other type). The quality of a derivation plan was then defined as 

1/Σ(to,td)d(to,td)

where the sum goes over all pairs of types in the derivation plan such that to is the original type and td the type derived from it and d(to,td) is the distance of the types.  Since historians failed, you are to write a program to help them. Given the codes of truck types, your program should find the highest possible quality of a derivation plan. 

Input

The input consists of several test cases. Each test case begins with a line containing the number of truck types, N, 2 <= N <= 2 000. Each of the following N lines of input contains one truck type code (a string of seven lowercase letters). You may assume that the codes uniquely describe the trucks, i.e., no two of these N lines are the same. The input is terminated with zero at the place of number of truck types.

Output

For each test case, your program should output the text "The highest possible quality is 1/Q.", where 1/Q is the quality of the best derivation plan.

Sample Input

4
aaaaaaa
baaaaaa
abaaaaa
aabaaaa
0

Sample Output

The highest possible quality is 1/3.

Source

問題描述:給定一些車牌號,通過比較兩個車牌號相同位置字元不同的個數作為權值,問使得這些車牌相連的最小代價

解題思路:簡單最小生成樹問題,使用Kruskal演算法。

AC的C++程式:

#include<iostream>
#include<string>
#include<algorithm>

using namespace std;

const int N=2005;
int pre[N];

void init(int n)
{
	for(int i=0;i<=n;i++)
	  pre[i]=i;
}

int find(int x)
{
	if(x!=pre[x])
	  pre[x]=find(pre[x]);
	return pre[x];
}

bool join(int x,int y)
{
	int fx=find(x);
	int fy=find(y);
	if(fx!=fy){
		pre[fx]=fy;
		return true;
	}
	return  false;
}

struct Edge{
	int a,b,c;
	bool operator<(const Edge &t)const
	{
		return c<t.c;
	}
}e[N*N];

char g[N][10];

int main()
{
	int n;
	while(~scanf("%d",&n)&&n){
		init(n);
		for(int i=1;i<=n;i++)
		  scanf("%s",g[i]);
		int k=0;
		for(int i=1;i<=n;i++)
		  for(int j=i+1;j<=n;j++){
		  	int val=0;
		  	for(int t=0;t<7;t++)
		  	  if(g[i][t]!=g[j][t])
		  	    val++;
		  	e[k].a=i,e[k].b=j,e[k].c=val;
		  	k++;
		  }
		sort(e,e+k);
		int ans=0,cnt=0;
		for(int i=0;i<k;i++){
			if(join(e[i].a,e[i].b)){//不構成環 
				ans+=e[i].c;
				cnt++;
				if(cnt==n-1)
				  break;
			}
		}
		printf("The highest possible quality is 1/%d.\n",ans);
	}
	return 0;
}