1. 程式人生 > >POJ 3273 Monthly Expense(二分查詢)

POJ 3273 Monthly Expense(二分查詢)

Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi ≤ 10,000) that he will need to spend each day over the next N (1 ≤ N ≤ 100,000) days.

FJ wants to create a budget for a sequential set of exactly M (1 ≤ M ≤ N) fiscal periods called "fajomonths". Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.

FJ's goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.

Input

Line 1: Two space-separated integers: N and M Lines 2.. N+1: Line i+1 contains the number of dollars Farmer John spends on the ith day

Output

Line 1: The smallest possible monthly limit Farmer John can afford to live with.

Sample Input

7 5
100
400
300
100
500
101
400

Sample Output

500

Hint

If Farmer John schedules the months so that the first two days are a month, the third and fourth are a month, and the last three are their own months, he spends at most $500 in any month. Any other method of scheduling gives a larger minimum monthly limit.

N種開銷,劃分成M塊,求每個月最小的最大開銷,expense(所求)最小為N種開銷中的最大值,最大為開銷總合。

進行二分。求expense.(這不是平均值,,,,,,,,)

#include<stdio.h>
#define maxn  100000
int a[maxn+10];
int main()
{
    int n,m,sum=0,maxmoney=0,expense,mid;
    scanf("%d %d",&n,&m);
    for(int i=0;i<n;i++)
    {
        scanf("%d",&a[i]);
        sum+=a[i];
        if(a[i]>maxmoney)
            maxmoney=a[i];
    }
    //printf("maxmoney=%d sum=%d\n",maxmoney,sum);
    int left=maxmoney,right=sum;
    while(left<=right)
    {
        mid=(left+right)/2;
        //printf("\n%middle=%d\n",mid);
        int period=0,costsum=0;
        for(int i=0;i<n;i++)
        {
           // printf("***i=%d\n",i);
            if(costsum+a[i]<mid)
            {
                costsum+=a[i];
               // printf("a[%d]=%d costsum=%d\n",i,a[i],costsum);
            }
            else if(costsum+a[i]==mid)
            {
                period++;
                costsum=0;
                //printf("period=%d costsum=%d\n",period,costsum);
            }
            else
            {
                period++;
                costsum=a[i];
               // printf("period=%d costsum=a[%d]=%d\n",period,i,costsum);
            }
        }
        if(costsum<mid&&costsum!=0)
          period++;
        //printf("period=%d\n",period);
        if(period<=m)
        {
            //若此時period==m&&right==left,right-1就會退出迴圈
            expense=mid;
            right=mid-1;
        }
        else
        {
            left=mid+1;
        }
    }
    printf("%d\n",expense);
    return 0;
}