1. 程式人生 > >POJ 3624 Charm Bracelet(01 揹包)

POJ 3624 Charm Bracelet(01 揹包)

題目傳送門

Description

Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a 'desirability' factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M

 (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

* Line 1: Two space-separated integers: N and M * Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi

 and Di

Output

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input

4 6
1 4
2 6
3 12
2 7

Sample Output

23

Source

題解:01揹包裸題,主要是優化,見程式碼,dp[i][j]表示的是前i個物品放入容量為j的容器裡能夠產生的最大價值。

大家可以看這個大牛題解,講的很詳細。

#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
int dp[13100];
int n,m,wei[13100],val[13100];
int main()
{
    while(cin>>n>>m)
    {
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=n;i++)
        {
            cin>>wei[i]>>val[i];
        }
        for(int i=1;i<=n;i++)
            for(int j=m;j>=wei[i];j--)
            {
                dp[j]=max(dp[j],dp[j-wei[i]]+val[i]);
            }
        cout<<dp[m]<<endl;
    }
    return 0;
}