1. 程式人生 > >POJ 3181 Dollar Dayz(動態規劃+大數)

POJ 3181 Dollar Dayz(動態規劃+大數)

題目傳送門

Description

Farmer John goes to Dollar Days at The Cow Store and discovers an unlimited number of tools on sale. During his first visit, the tools are selling variously for $1, $2, and $3. Farmer John has exactly $5 to spend. He can buy 5 tools at $1 each or 1 tool at $3 and an additional 1 tool at $2. Of course, there are other combinations for a total of 5 different ways FJ can spend all his money on tools. Here they are:   

        1 @ US$3 + 1 @ US$2

        1 @ US$3 + 2 @ US$1

        1 @ US$2 + 3 @ US$1

        2 @ US$2 + 1 @ US$1

        5 @ US$1

Write a program than will compute the number of ways FJ can spend N dollars (1 <= N <= 1000) at The Cow Store for tools on sale with a cost of $1..$K (1 <= K <= 100).

Input

A single line with two space-separated integers: N and K.

Output

A single line with a single integer that is the number of unique ways FJ can spend his money.

Sample Input

5 3

Sample Output

5

Source

題意:給你兩個數n,k,讓你用1到k這k個數表示n,問有幾種方法

題解:大家看看這兩個部落格,可以說是很詳細了===>>大牛部落格1大牛部落格2

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
long long n,m,inf=1e18,a[1110][110],b[1110][110];
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        memset(a,0,sizeof(a));//不能忘
        memset(b,0,sizeof(b));
        for(int i=1;i<=m;i++)
            a[0][i]=1;
        for(int j=1;j<=m;j++)
            for(int i=1;i<=n;i++)
            {
                if(i<j)
                {
                    a[i][j]=a[i][j-1];
                    b[i][j]=b[i][j-1];
                    continue;//不能忘
                }
                b[i][j]=b[i][j-1]+b[i-j][j]+(a[i-j][j]+a[i][j-1])/inf;
                a[i][j]=(a[i-j][j]+a[i][j-1])%inf;//a[i][j]=a[i-j][j]+(a[i][j-1])%inf;括號不能錯了
            }
        if(b[n][m])
            printf("%I64d",b[n][m]);//記錄大數前17位
        printf("%I64d",a[n][m]);//記錄大數後17位
        cout<<endl;
    }
    return 0;
}