1. 程式人生 > >POJ-2352 Stars(樹狀陣列應用)

POJ-2352 Stars(樹狀陣列應用)

Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.


For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1
0

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

題目大意:按照y的大小,相等則按照x的大小,有序的給出多個點的座標,每個座標表示一顆星星,每顆星星都有等級,它們的等級等於在它們左下角的星星數量。(題目中的圖和解釋)

思路:這不是二維偏序嗎?不對,給出來的已經是有序的座標,不用再考慮偏序。看下資料範圍,暴力是不可能了,那隻能想別的方法了。實際上,,,我是來練樹狀陣列才找到這個題的......

樹狀陣列的經典應用是不會的,索引陣列是不可能抽象出來的,就只能靠它的基本功能來套題了。因為座標已經是有序的,所以求等級數就相當於求它前面的星星數,即字首和。。。用樹狀陣列來實現,求每個星星的字首和並記錄。因為資料有序,所以不用考慮後面的星星會對前面的等級造成影響。無序則需要先進行排序處理。

程式碼如下:

#include<cmath>
#include<queue>
#include<stack>
#include<deque>
#include<vector>
#include<cstdio>
#include<string>
#include<cstring>
#include<iostream>
#include<algorithm>
#define per(i,a,b) for(int i=a;i<=b;++i)
#define inf 0xf3f3f3f
#define LL long long 
using namespace std;
int n,p[50005],c[50005];
int lowbit(int k)
{
	return k&(-k);
}
void add(int x,int k)
{
	for(int i=x;i<=50005;i+=lowbit(i))
	c[i]+=k;
}
int sum(int x)
{
	int s=0;
	for(int i=x;i>0;i-=lowbit(i))
	s+=c[i];
	return s; 
}
int main()
{
	int x,y;
	while(cin>>n)
	{
		memset(p,0,sizeof(p));
		memset(c,0,sizeof(c));
		per(i,0,n-1)
		{
			cin>>x>>y;
			x++;//樹狀陣列從1開始 
			p[sum(x)]++;//等級數增加 ,sum是字首和,c儲存的是等級數
			add(x,1);//因為題目保證了資料輸入的有序,所以不用管後面輸入的會影響前面的字首
		}
		per(i,0,n-1) printf("%d\n",p[i]);
	}	
	return 0;
}