1. 程式人生 > >hud 2594Simpsons’ Hidden Talents(kmp 字首字尾匹配 )

hud 2594Simpsons’ Hidden Talents(kmp 字首字尾匹配 )

Simpsons’ Hidden Talents

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 14827    Accepted Submission(s): 5091  

Problem Description

Homer: Marge, I just figured out a way to discover some of the talents we weren’t aware we had. Marge: Yeah, what is it? Homer: Take me for example. I want to find out if I have a talent in politics, OK? Marge: OK. Homer: So I take some politician’s name, say Clinton, and try to find the length of the longest prefix in Clinton’s name that is a suffix in my name. That’s how close I am to being a politician like Clinton Marge: Why on earth choose the longest prefix that is a suffix??? Homer: Well, our talents are deeply hidden within ourselves, Marge. Marge: So how close are you? Homer: 0! Marge: I’m not surprised. Homer: But you know, you must have some real math talent hidden deep in you. Marge: How come? Homer: Riemann and Marjorie gives 3!!! Marge: Who the heck is Riemann? Homer: Never mind. Write a program that, when given strings s1 and s2, finds the longest prefix of s1 that is a suffix of s2.

Input

Input consists of two lines. The first line contains s1 and the second line contains s2. You may assume all letters are in lowercase.

Output

Output consists of a single line that contains the longest string that is a prefix of s1 and a suffix of s2, followed by the length of that prefix. If the longest such string is the empty string, then the output should be 0. The lengths of s1 and s2 will be at most 50000.

Sample Input

clinton homer riemann marjorie

Sample Output

0 rie 3

Source

Recommend

lcy   |   We have carefully selected several similar problems for you:  1686 2595 2596 2597 2598 

自己完全獨立過的,紀念一下。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define maxn 50005
using namespace std;
char t[maxn];
char p[maxn];
int f[maxn];
void getfail(char*p,int*f)
{f[0]=f[1]=0;
int m=strlen(p);
for(int i=1;i<m;i++)
{
    int j=f[i];
    while(j&&p[i]!=p[j])
    j=f[j];
    f[i+1]=(p[i]==p[j])?j+1:0;

}

}
int kmp(char*t,char*p,int*f)
{
    int n=strlen(t);
    int m=strlen(p);
    int j=0;
    getfail(p,f);
    for(int i=0;i<n;i++)
    {
        while(j&&t[i]!=p[j])
        j=f[j];
        if(t[i]==p[j])
            j++;
        if(i==n-1)
            return j;
    }
}
int main()
{
    while(~scanf("%s%s",&t,&p))
    {
        int len=kmp(p,t,f);
        if(len==0)
            printf("0\n");
        else
        {
        for(int i=0;i<len;i++)
            printf("%c",t[i]);
            printf(" %d\n",len);
        }
    }
    return 0;
}