1. 程式人生 > >矩陣求斐波那契數列 -POJ 3070

矩陣求斐波那契數列 -POJ 3070

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

.

Given an integer n, your goal is to compute the last 4 digits of Fn

.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn

are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input

0
9
999999999
1000000000
-1

Sample Output

0
34
626
6875

Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

.

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

.

如下圖:

#include<cstdio>
#include<cstring>
using namespace std;

struct node {
	int m[3][3];
};
node a,e;
node mult(node a,node b) {
	node c;
	memset(c.m,0,sizeof(c.m));
	for(int i=1; i<3; i++) {
		for(int j=1; j<3; j++) {
			for(int k=1; k<3; k++) {
				c.m[i][j]+=(a.m[i][k]*b.m[k][j])%10000;
			}
		}
	}
	return c;
}
node cal(node a,int n) {
	node res;
	res = e;
	while(n) {
		if(n%2)
			res = mult(a,res);
		a = mult(a,a);
		n=n/2;
	}
	return res;
}

int main() {
	a.m[1][1]=1;
	a.m[1][2]=1;
	a.m[2][1]=1;
	a.m[2][2]=0;
	e.m[1][1]=1;
	e.m[1][2]=0;
	e.m[2][1]=0;
	e.m[2][2]=1;
	int n;
	while(~scanf("%d",&n) && n>=0) {
		node ans;
		ans=cal(a,n);
		printf("%d\n",ans.m[1][2]%10000);
	}
	return 0;
}