1. 程式人生 > >2033 】Alphacode (dp,有坑)

2033 】Alphacode (dp,有坑)

題幹:

Alice and Bob need to send secret messages to each other and are discussing ways to encode their messages: 

Alice: "Let's just use a very simple code: We'll assign 'A' the code word 1, 'B' will be 2, and so on down to 'Z' being assigned 26." 
Bob: "That's a stupid code, Alice. Suppose I send you the word 'BEAN' encoded as 25114. You could decode that in many different ways!” 
Alice: "Sure you could, but what words would you get? Other than 'BEAN', you'd get 'BEAAD', 'YAAD', 'YAN', 'YKD' and 'BEKD'. I think you would be able to figure out the correct decoding. And why would you send me the word ‘BEAN’ anyway?” 
Bob: "OK, maybe that's a bad example, but I bet you that if you got a string of length 500 there would be tons of different decodings and with that many you would find at least two different ones that would make sense." 
Alice: "How many different decodings?" 
Bob: "Jillions!"


For some reason, Alice is still unconvinced by Bob's argument, so she requires a program that will determine how many decodings there can be for a given string using her code. 

Input

Input will consist of multiple input sets. Each set will consist of a single line of digits representing a valid encryption (for example, no line will begin with a 0). There will be no spaces between the digits. An input line of '0' will terminate the input and should not be processed

Output

For each input set, output the number of possible decodings for the input string. All answers will be within the range of a long variable.

Sample Input

25114
1111111111
3333333333
0

Sample Output

6
89
1

解題報告:

   有點坑啊,,直接dp[i]=dp[i-1]了,,殊不知,如果這一位為0的話,,就得dp[i]=dp[i-2]並且接下來的操作都不能參與了,也就是得直接continue才行、、、

  思路就是首先初始化成dp[i-1]的值(當然s[i]=='0'就另說了),然後xjb轉移一下就好了。。

AC程式碼:

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<queue>
#include<map>
#include<vector>
#include<set>
#include<string>
#include<cmath>
#include<cstring>
#define ll long long
#define pb push_back
#define pm make_pair
#define fi first
#define se second
using namespace std;
const int MAX = 2e5 + 5;
ll dp[MAX]; 
char s[MAX];
int main()
{
	while(cin>>(s+1)) {
		memset(dp,0,sizeof dp);
		int len = strlen(s+1);
		dp[0]=1;
		if(s[1] != '0') dp[1]=1;
		else break;
		for(int i = 2; i<=len; i++) {
			if(s[i] == '0') {
				dp[i] = dp[i-2];continue;
			}
			else dp[i] = dp[i-1];
			if(s[i-1] == '1') dp[i] += dp[i-2];
			if(s[i-1] == '2' && s[i] <= '6') dp[i] += dp[i-2];
			if(s[i] == '0' && (s[i-1]=='0'||s[i-1]>'2')) dp[i]=0;
			
		}
		printf("%lld\n",dp[len]);
	}
	//10110
	return 0 ;
 }

AC程式碼2:

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<queue>
#include<map>
#include<vector>
#include<set>
#include<string>
#include<cmath>
#include<cstring>
#define ll long long
#define pb push_back
#define pm make_pair
#define fi first
#define se second
using namespace std;
const int MAX = 2e5 + 5;
ll dp[MAX]; 
char s[MAX];
int main()
{
	while(cin>>(s+1)) {
		memset(dp,0,sizeof dp);
		int len = strlen(s+1);
		dp[0]=1;
		if(s[1] != '0') dp[1]=1;
		else break;
		for(int i = 2; i<=len; i++) {
			dp[i] = dp[i-1];
			if(s[i-1] == '1') dp[i] += dp[i-2];
			if(s[i-1] == '2' && s[i] <= '6') dp[i] += dp[i-2];
			if(s[i] == '0' && (s[i-1]=='0'||s[i-1]>'2')) dp[i]=0;
			if(s[i] == '0') dp[i] = dp[i-2];
		}
		printf("%lld\n",dp[len]);
	}
	//10110


	return 0 ;
 }

錯誤程式碼1:

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<queue>
#include<map>
#include<vector>
#include<set>
#include<string>
#include<cmath>
#include<cstring>
#define ll long long
#define pb push_back
#define pm make_pair
#define fi first
#define se second
using namespace std;
const int MAX = 2e5 + 5;
ll dp[MAX]; 
char s[MAX];
int main()
{
	while(cin>>(s+1)) {
		memset(dp,0,sizeof dp);
		int len = strlen(s+1);
		dp[0]=1;
		if(s[1] != '0') dp[1]=1;
		else break;
		for(int i = 2; i<=len; i++) {
			if(s[i] == '0') dp[i] = dp[i-2];
			else dp[i] = dp[i-1];
			if(s[i-1] == '1') dp[i] += dp[i-2];
			if(s[i-1] == '2' && s[i] <= '6') dp[i] += dp[i-2];
			if(s[i] == '0' && (s[i-1]=='0'||s[i-1]>'2')) dp[i]=0;
			
		}
		printf("%lld\n",dp[len]);
	}
	//10110
	return 0 ;
 }

總結:

  這題dp[0]=1是必須要賦值的,,因為你有dp[i] += dp[i-2],所以  i==2 的時候,需要用到dp[0]的狀態。