1. 程式人生 > >poj 1611 The Suspects(簡單並查集)

poj 1611 The Suspects(簡單並查集)

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. 
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP). 
Once a member in a group is a suspect, all members in the group are suspects. 
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space. 
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output

For each case, output the number of suspects in one line.

Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output

4
1
1

題意:有很多組學生,在同一個組的學生經常會接觸,也會有新的同學的加入。但是SARS是很容易傳染的,只要在改組有一位同學感染SARS,那麼該組的所有同學都被認為得了SARS。現在的任務是計算出有多少位學生感染SARS了。假定編號為0的同學是得了SARS的。

#pragma GCC optimize(2)
#include<stdio.h>
#include<algorithm>
#include<iostream>
#include<string.h>
#include<set>
#include<vector>
#include<string>
#include<queue>
using namespace std;
const int maxn = 3e4 + 500;
const int inf = 0x3f3f3f3f;
typedef long long ll;
int f[maxn];
int a[maxn];
int find(int x)
{
	if (x == f[x])
	{
		return x;
	}
	else
	{
		return f[x] = find(f[x]);
	}
}
void merge(int x, int y)
{
	int u = find(x);
	int v = find(y);
	if (u != v)
	{
		if (u < v)
		{
			f[v] = u;
		}
		else
		{
			f[u] = v;
		}
	}
}
int main()
{
	//freopen("C://input.txt", "r", stdin);
	int n, m;
	while (scanf("%d%d", &n, &m) != EOF)
	{
		int sum = 1;
		int k;
		if (n == 0 && m == 0)
		{
			break;
		}
		for (int i = 1; i <= n; i++)
		{
			f[i] = i;
		}
		for (int i = 1; i <= m; i++)
		{
			scanf("%d", &k);
			if (k >= 1)
			{
				scanf("%d", &a[0]);
				for (int j = 1; j < k; j++)
				{
					scanf("%d", &a[j]);
					merge(a[0], a[j]);
				}
			}
		}
		for (int i = 1; i <= n; i++)
		{
			if (find(i) == f[0])
			{
				sum++;
			}
		}
		printf("%d\n", sum);
	}
	return 0;
}