1. 程式人生 > >POJ 1716 Intervals 差分約束

POJ 1716 Intervals 差分約束

You are given n closed, integer intervals [ai, bi] and n integers c1, ..., cn.
Write a program that:
reads the number of intervals, their end points and integers c1, ..., cn from the standard input,
computes the minimal size of a set Z of integers which has at least ci common elements with interval [ai, bi], for each i=1,2,...,n,
writes the answer to the standard output.

Input

The first line of the input contains an integer n (1 <= n <= 50000) -- the number of intervals. The following n lines describe the intervals. The (i+1)-th line of the input contains three integers ai, bi and ci separated by single spaces and such that 0 <= ai <= bi <= 50000 and 1 <= ci <= bi - ai+1.

Output

The output contains exactly one integer equal to the minimal size of set Z sharing at least ci elements with interval [ai, bi], for each i=1,2,...,n.

Sample Input

5
3 7 3
8 10 3
6 8 1
1 3 1
10 11 1

Sample Output

6

題意:

給出數軸上的n個閉合int型區間。現在要在數軸上任意取一堆元素,構成一個元素集合V,要求給出的每個區間和元素集合V的交集至少有兩個不同的元素,求集合V最小的元素個數。

根據題目的資訊,我們可以得出d[y]-d[x-1]>=c;

然後我們轉換一下:

d[y]>=d[x-1]+c;

不要忘了一下條件:

d[i]-d[i-1]>=0;

d[i]-d[i-1]<=0;

沒有這些條件邊與邊之間是串不起來的。

然後再求最長路就可以了。

程式碼如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <queue>
#include <vector>
using namespace std;
const int maxn=50005;
const int INF=0x3f3f3f3f;
int n;
struct edge
{
    int e,len;
};
vector <edge> ve[maxn];
int d[maxn];
int maxx,minn;
int vis[maxn];
void init()
{
    maxx=-1;
    minn=INF;
    for (int i=0;i<maxn;i++)
        d[i]=-INF;
    for (int i=0;i<maxn;i++)
        ve[i].clear();
    memset (vis,0,sizeof(vis));
}
void spfa()
{
    d[minn]=0;
    queue<int>q;
    q.push(minn);
    while (!q.empty())
    {
        int u=q.front(); q.pop();
        vis[u]=0;
        for (int i=0;i<ve[u].size();i++)
        {
            int v=ve[u][i].e;
            if(d[v]<d[u]+ve[u][i].len)
            {
                d[v]=d[u]+ve[u][i].len;
                if(!vis[v])
                {
                    q.push(v);
                    vis[v]=1;
                }
            }
        }
    }
    printf("%d\n",d[maxx]);
}
int main()
{
    scanf("%d",&n);
    init();
    for (int i=0;i<n;i++)
    {
        int x,y,len;
        scanf("%d%d%d",&x,&y,&len);
        maxx=max(maxx,y);
        minn=min(minn,x-1);
        edge temp;
        temp.e=y; temp.len=len;
        ve[x-1].push_back(temp);
    }
    for (int i=minn+1;i<=maxx;i++)
    {
        edge temp1,temp2;
        temp1.e=i; temp1.len=0;
        temp2.e=i-1; temp2.len=-1;
        ve[i-1].push_back(temp1);
        ve[i].push_back(temp2);
    }
    spfa();
    return 0;
}