1. 程式人生 > >Combinations(組合數)

Combinations(組合數)

Combinations
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 9095 Accepted: 4199

Description

Computing the exact number of ways that N things can be taken M at a time can be a great challenge when N and/or M become very large. Challenges are the stuff of contests. Therefore, you are to make just such a computation given the following: 
GIVEN: 5 <= N <= 100; 5 <= M <= 100; M <= N 
Compute the EXACT value of: C = N! / (N-M)!M! 
You may assume that the final value of C will fit in a 32-bit Pascal LongInt or a C long. For the record, the exact value of 100! is: 
93,326,215,443,944,152,681,699,238,856,266,700,490,715,968,264,381,621, 468,592,963,895,217,599,993,229,915,608,941,463,976,156,518,286,253, 697,920,827,223,758,251,185,210,916,864,000,000,000,000,000,000,000,000 

Input

The input to this program will be one or more lines each containing zero or more leading spaces, a value for N, one or more spaces, and a value for M. The last line of the input file will contain a dummy N, M pair with both values equal to zero. Your program should terminate when this line is read.

Output

The output from this program should be in the form: 
N things taken M at a time is C exactly. 

Sample Input

100  6
20  5
18  6
0  0

Sample Output

100 things taken 6 at a time is 1192052400 exactly.
20 things taken 5 at a time is 15504 exactly.

#include <stdio.h>
int main()
{
    int a,b,c,i,temp_a,temp_b;
    double s1,s2;
    while(scanf("%d%d",&a,&b)!=EOF)
    {
        if (a==0&&b==0)
        {
            break;
        }
        temp_a=a;
        temp_b=b;
        if(a-b<b)
        {
            b=a-b;
        }
        s1=s2=1;
        for (i=1;i<=b;i++)
        {
            s1*=i;//s1為b的階乘
            s2*=a;//s2為a的階乘除以a-b的階乘
            a--;
        }
        printf("%d things taken %d at a time is %.0lf exactly.\n",temp_a,temp_b,(s2/s1));
    }
    return 0;
}


#include <stdio.h>  
#include <stdlib.h>  
  
int main()  
{  
    int n,m,j;  
    double sum,i;  
  
    while(scanf("%d%d",&n,&m)!=EOF&&(n||m))  
    {if(n<5||n>100||m<5||m>100||n<m)  
       break;  
        sum=1.0;  
        j=m;  
        for(i=n; i>n-m; i--)  
        {  
            sum*=(i/j);  
            j--;  
        }  
  
  
        printf("%d things taken %d at a time is %0.lf exactly.\n",n,m,sum);  
    }  
  
  
    return 0;  
}