1. 程式人生 > >PAT (Advanced Level) Practice 1138 Postorder Traversal (25 分) 樹的重構

PAT (Advanced Level) Practice 1138 Postorder Traversal (25 分) 樹的重構

Suppose that all the keys in a binary tree are distinct positive integers. Given the preorder and inorder traversal sequences, you are supposed to output the first number of the postorder traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 50,000), the total number of nodes in the binary tree. The second line gives the preorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the first number of the postorder traversal sequence of the corresponding binary tree.

Sample Input:

7
1 2 3 4 5 6 7
2 3 1 5 4 7 6

Sample Output:

3

 題意

給出樹的前序和中序,求後序的第一個節點的值。

程式碼如下:
 

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <vector>
#include <map>
using namespace std;
const int maxn=5*1e4+5;
int n;
int flag=0;
vector<int>pre;
vector<int>in;
vector<int>post;
map<int,int>ma;
int pos=0;
void Post (int l,int r)
{
    if(post.size())
    {
        flag=1;
        return;
    }
    if(flag)
    {
        return;
    }
    if(l>r)
    {
        return;
    }
    int temp=pre[pos++];
    int loc=ma[temp];
    Post(l,loc-1);
    Post(loc+1,r);
    post.push_back(temp);
}
int main()
{
    scanf("%d",&n);
    for (int i=0;i<n;i++)
    {
        int x;
        scanf("%d",&x);
        pre.push_back(x);
    }
    for (int i=0;i<n;i++)
    {
        int x;
        scanf("%d",&x);
        in.push_back(x);
        ma[x]=i;
    }
    Post(0,n-1);
    printf("%d\n",post[0]);
    return 0;
}