1. 程式人生 > >PTA 中國大學MOOC-陳越、何欽銘-資料結構-2018秋 06-圖2 Saving James Bond

PTA 中國大學MOOC-陳越、何欽銘-資料結構-2018秋 06-圖2 Saving James Bond

06-圖2 Saving James Bond - Easy Version (25 分)

This time let us consider the situation in the movie "Live and Let Die" in which James Bond, the world's most famous spy, was captured by a group of drug dealers. He was sent to a small piece of land at the center of a lake filled with crocodiles. There he performed the most daring action to escape -- he jumped onto the head of the nearest crocodile! Before the animal realized what was happening, James jumped again onto the next big head... Finally he reached the bank before the last crocodile could bite him (actually the stunt man was caught by the big mouth and barely escaped with his extra thick boot).

Assume that the lake is a 100 by 100 square one. Assume that the center of the lake is at (0,0) and the northeast corner at (50,50). The central island is a disk centered at (0,0) with the diameter of 15. A number of crocodiles are in the lake at various positions. Given the coordinates of each crocodile and the distance that James could jump, you must tell him whether or not he can escape.

Input Specification:

Each input file contains one test case. Each case starts with a line containing two positive integers N (≤100), the number of crocodiles, and D, the maximum distance that James could jump. Then N lines follow, each containing the (x,y) location of a crocodile. Note that no two crocodiles are staying at the same position.

Output Specification:

For each test case, print in a line "Yes" if James can escape, or "No" if not.

Sample Input 1:

14 20
25 -15
-25 28
8 49
29 15
-35 -2
5 28
27 -29
-8 -28
-20 -35
-25 -20
-13 29
-30 15
-35 40
12 12

Sample Output 1:

Yes

Sample Input 2:

4 13
-12 12
12 12
-12 -12
12 -12

Sample Output 2:

No

 程式碼及註釋如下:

/*
我感覺此題用bfs好做一些,所以用了bfs...
起點需要特殊處理下,可以假設讓007在原點出發,跳躍的距離多加上小島的半徑即可...
然後其他點與佇列中的點比較,看看絕對距離是否小於跳躍距離,小就入隊...
終止條件就是看看橫或縱座標加上跳躍距離是否可以到達邊界...
沒想到居然一遍過了....
*/
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <queue>
#include <math.h>
using namespace std;
const int maxn=105;
int n,d;
struct node
{
    int x,y;
};
queue<int>q;
node nn[maxn];
int vis[maxn];
void init()
{
    memset (vis,0,sizeof(vis));
}
bool Canreach (int x,int y,double dis)
{
    double k=sqrt((nn[x].x-nn[y].x)*(nn[x].x-nn[y].x)+(nn[x].y-nn[y].y)*(nn[x].y-nn[y].y));
    if(k>dis)
        return false;
    else
        return true;
}
bool bfs ()
{
    vis[0]=1;
    for (int i=1;i<=n;i++)
    {
        if(Canreach(0,i,d+15))
        {
            q.push(i);
            vis[i]=1;
        }
    }
    while (!q.empty())
    {
        int k=q.front();
        if(nn[k].x+d>=50||nn[k].y+d>=50)
            return true;
        q.pop();
        for (int i=1;i<=n;i++)
        {
            if(!vis[i]&&Canreach(k,i,d))
            {
                q.push(i);
                vis[i]=1;
            }
        }
    }
    return false;
}
int main()
{
    init();
    scanf("%d%d",&n,&d);
    nn[0].x=0; nn[0].y=0;
    for (int i=1;i<=n;i++)
        scanf("%d%d",&nn[i].x,&nn[i].y);
    if(bfs())
        printf("Yes\n");
    else
        printf("No\n");
    return 0;
}