1. 程式人生 > >BestCoder Round #84 1002 hdu 5748 最長上升子序列

BestCoder Round #84 1002 hdu 5748 最長上升子序列

連結:戳這裡

Bellovin Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Problem Description
Peter has a sequence a1,a2,...,an and he define a function on the sequence -- F(a1,a2,...,an)=(f1,f2,...,fn), where fi is the length of the longest increasing subsequence ending with ai.

Peter would like to find another sequence b1,b2,...,bn in such a manner that F(a1,a2,...,an) equals to F(b1,b2,...,bn). Among all the possible sequences consisting of only positive integers, Peter wants the lexicographically smallest one.

The sequence a1,a2,...,an is lexicographically smaller than sequence b1,b2,...,bn, if there is such number i from 1 to n, that ak=bk for 1≤k<i and ai<bi.
 
Input
There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:

The first contains an integer n (1≤n≤100000) -- the length of the sequence. The second line contains n integers a1,a2,...,an (1≤ai≤109).
 
Output
For each test case, output n integers b1,b2,...,bn (1≤bi≤109) denoting the lexicographically smallest sequence.
 
Sample Input
3
1
10
5
5 4 3 2 1
3
1 3 5
 
Sample Output
1
1 1 1 1 1
1 2 3
 

思路:

在求嚴格最長上升子序列的時候更新答案就可以了

程式碼:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<string>
#include<vector>
#include <ctime>
#include<queue>
#include<set>
#include<map>
#include<stack>
#include<iomanip>
#include<cmath>
#define mst(ss,b) memset((ss),(b),sizeof(ss))
#define maxn 0x3f3f3f3f
#define MAX 1000100
///#pragma comment(linker, "/STACK:102400000,102400000")
typedef long long ll;
typedef unsigned long long ull;
#define INF (1ll<<60)-1
using namespace std;
int n;
int a[100100];
int len[100100];
int s[100100];
int main(){
    int T;
    scanf("%d",&T);
    while(T--){
        scanf("%d",&n);
        mst(len,0);
        mst(s,0);
        for(int i=1;i<=n;i++) scanf("%d",&a[i]);
        len[1]=1;
        s[1]=a[1];
        int cnt=1;
        for(int i=2;i<=n;i++){
            if(a[i]>s[cnt]){
                s[++cnt]=a[i];
                len[i]=cnt;
                continue;
            } else {
                int x=lower_bound(s+1,s+cnt+1,a[i])-s;
                if(x>cnt) len[i]=cnt;
                else len[i]=x;
                s[x]=a[i];
            }
        }
        for(int i=1;i<=n;i++) {
            if(i==n) cout<<len[i]<<endl;
            else cout<<len[i]<<" ";
        }
    }
    return 0;
}
/*
10
5
3 2 1 1 4
10
7
1 1 2 2 1 1 2
*/