1. 程式人生 > >poj 3070 Fibonacci 【矩陣快速冪 求第N個斐波那契數%1000】

poj 3070 Fibonacci 【矩陣快速冪 求第N個斐波那契數%1000】

Fibonacci
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 11123 Accepted: 7913

Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn

. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input

0
9
999999999
1000000000
-1

Sample Output

0
34
626
6875

Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

.

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

.

題意:給你一個求解第N個斐波那契數的公式。 讓你求出Fn % 10000。

構造單位矩陣,然後就是矩陣快速冪了。

AC程式碼:

#include <cstdio>
#include <cstring>
#include <algorithm>
#define MAXN 100
#define LL long long
#define MOD 10000
using namespace std;
struct Matrix
{
    LL a[MAXN][MAXN];
    int r, c;//行數 列數
};
Matrix ori, res;//初始矩陣 和 結果矩陣
void init()//初始化矩陣
{
    memset(res.a, 0, sizeof(res.a));
    res.r = 2; res.c = 2;
    for(int i = 1; i <= 2; i++)//構造單位矩陣
        res.a[i][i] = 1;
    ori.r = 2; ori.c = 2;
    ori.a[1][1] = ori.a[1][2] = ori.a[2][1] = 1;
    ori.a[2][2] = 0;
}
Matrix multi(Matrix x, Matrix y)
{
    Matrix z;
    memset(z.a, 0, sizeof(z.a));
    z.r = x.r, z.c = y.c;//新矩陣行數等於x矩陣的行數 列數等於y矩陣的列數
    for(int i = 1; i <= x.r; i++)//x矩陣的行數
    {
        for(int k = 1; k <= x.c; k++)//矩陣x的列數等於矩陣y的行數 即x.c = y.r
        {
            if(x.a[i][k] == 0) continue;//優化
            for(int j = 1; j<= y.c; j++)//y矩陣的列數
                z.a[i][j] = (z.a[i][j] + (x.a[i][k] * y.a[k][j]) % MOD) % MOD;
        }
    }
    return z;
}
void Matrix_mod(int n)
{
    while(n)//N次冪
    {
        if(n & 1)
            res = multi(ori, res);
        ori = multi(ori, ori);
        n >>= 1;
    }
    printf("%lld\n", res.a[1][2] % MOD);
}
int main()
{
    int N;
    while(scanf("%d", &N), N!=-1)
    {
        init();//初始化單位矩陣
        Matrix_mod(N);//矩陣快速冪
    }
    return 0;
}