1. 程式人生 > >PAT (Advanced Level) Practice 1146 Topological Order (25 分) 拓撲排序

PAT (Advanced Level) Practice 1146 Topological Order (25 分) 拓撲排序

This is a problem given in the Graduate Entrance Exam in 2018: Which of the following is NOT a topological order obtained from the given directed graph? Now you are supposed to write a program to test each of the options.

gre.jpg

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (≤ 1,000), the number of vertices in the graph, and M (≤ 10,000), the number of directed edges. Then M lines follow, each gives the start and the end vertices of an edge. The vertices are numbered from 1 to N. After the graph, there is another positive integer K (≤ 100). Then K lines of query follow, each gives a permutation of all the vertices. All the numbers in a line are separated by a space.

Output Specification:

Print in a line all the indices of queries which correspond to "NOT a topological order". The indices start from zero. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line. It is graranteed that there is at least one answer.

Sample Input:

6 8
1 2
1 3
5 2
5 4
2 3
2 6
3 4
6 4
5
1 5 2 3 6 4
5 1 2 6 3 4
5 1 2 3 6 4
5 2 1 6 3 4
1 2 3 4 5 6

Sample Output:

3 4

程式碼如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <vector>
using namespace std;
const int maxn=1005;
int n,m,q;
int in[maxn],out[maxn];
int tin[maxn],re[maxn];
vector<int> ve[maxn],no;
void init()
{
    memset (in,0,sizeof(in));
}
void tinit()
{
    for (int i=1;i<=n;i++)
    {
        tin[i]=in[i];
    }
}
int main()
{
    init();
    scanf("%d%d",&n,&m);
    while (m--)
    {
        int x,y;
        scanf("%d%d",&x,&y);
        ve[x].push_back(y);
        in[y]++;
    }
    scanf("%d",&q);
    for (int k=0;k<q;k++)
    {
        tinit();
        for (int i=0;i<n;i++)
            scanf("%d",&re[i]);
        for (int i=0;i<n;i++)
        {
            if(tin[re[i]])
            {
                no.push_back(k);
                break;
            }
            else
            {
                for (int j=0;j<ve[re[i]].size();j++)
                {
                    tin[ve[re[i]][j]]--;
                }
            }
        }
    }
    int Size=no.size();
        for (int i=0;i<Size;i++)
            printf("%d%c",no[i],i==Size-1?'\n':' ');
    return 0;
}