1. 程式人生 > >PAT (Advanced Level) Practice 1142 Maximal Clique (25 分) 暴力

PAT (Advanced Level) Practice 1142 Maximal Clique (25 分) 暴力

A clique is a subset of vertices of an undirected graph such that every two distinct vertices in the clique are adjacent. A maximal clique is a clique that cannot be extended by including one more adjacent vertex. (Quoted from https://en.wikipedia.org/wiki/Clique_(graph_theory))

Now it is your job to judge if a given subset of vertices can form a maximal clique.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers Nv (≤ 200), the number of vertices in the graph, and Ne, the number of undirected edges. Then Ne lines follow, each gives a pair of vertices of an edge. The vertices are numbered from 1 to Nv.

After the graph, there is another positive integer M (≤ 100). Then M lines of query follow, each first gives a positive number K (≤ Nv), then followed by a sequence of K distinct vertices. All the numbers in a line are separated by a space.

Output Specification:

For each of the M queries, print in a line Yes

if the given subset of vertices can form a maximal clique; or if it is a clique but not a maximal clique, print Not Maximal; or if it is not a clique at all, print Not a Clique.

Sample Input:

8 10
5 6
7 8
6 4
3 6
4 5
2 3
8 2
2 7
5 3
3 4
6
4 5 4 3 6
3 2 8 7
2 2 3
1 1
3 4 3 6
3 3 2 1

Sample Output:

Yes
Yes
Yes
Yes
Not Maximal
Not a Clique

直接暴力求解, 判斷兩個是否相鄰。 。。

程式碼如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <vector>
#include <stack>
using namespace std;
const int maxn=205;
int ma[maxn][maxn];
int n,m,q;
int a[maxn],vis[maxn];
void init()
{
    memset (ma,0,sizeof(ma));
    memset (vis,0,sizeof(vis));
}
int main()
{
    scanf("%d%d",&n,&m);
    init();
    while (m--)
    {
        int x,y;
        scanf("%d%d",&x,&y);
        ma[x][y]=ma[y][x]=1;
    }
    scanf("%d",&q);
    while (q--)
    {
        memset (vis,0,sizeof(vis));
       int t,flag1=0,flag2=0;
       scanf("%d",&t);
       for (int i=0;i<t;i++)
       {
          scanf("%d",&a[i]);
          vis[a[i]]=1;
       }
       for (int i=0;i<t-1;i++)
       {
           for (int j=i+1;j<t;j++)
              if(!ma[a[i]][a[j]])
             {
               flag1=1;
               break;
             }
       }
       if(flag1)
       {
           printf("Not a Clique\n");
       }
       else
       {
           for (int i=1;i<=n;i++)
           {
               if(!vis[i])
               {
                   int num=0;
                   for (int j=0;j<t;j++)
                   {
                       if(ma[i][a[j]])
                          num++;
                   }
                   if(num==t)
                   {
                       flag2=1;
                       break;
                   }
               }
           }
           if(flag2)
             printf("Not Maximal\n");
           else
             printf("Yes\n");
       }
    }
    return 0;
}