1. 程式人生 > >poj-2406-Power Strings

poj-2406-Power Strings

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = “abc” and b = “def” then a*b = “abcdef”. If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = “” (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3
Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

暴力求解

/*
    Name: poj 2406
    Author: long long ago
    Date: 17/03/16 10:04
    Description: http://poj.org/problem?id=2406   kmp演算法 
*/

#include <iostream>
#include <cstdio> #include <vector> #include <cstring> #include <cstdlib> using namespace std; char a[1000010]; int kmp(int len){ int i, j, k, ans = 0; for (k = 1; k <= len/2; k++){ if (len%k) continue; //k需要是len的約數 for (i = 0; i < len; i++){ if (a[i%k] != a[i]){ break; } } if (i == len) break; } if (k <= len/2){ return len/k; }else{ return 1; } } int main(){ int i, j, ans, len; while(scanf("%s", &a)){ if (!strcmp(a, ".")){ break; } len = strlen(a); printf("%d\n", kmp(len)); } return 0; }

next陣列做法
kmp
next表示模式串如果第i位(設str[0]為第0位)與文字串第j位不匹配則要回到第next[i]位繼續與文字串第j位匹配。則模式串第1位到next[n]與模式串第n-next[n]位到n位是匹配的。所以思路和上面一樣,如果n%(n-next[n])==0,則存在重複連續子串,長度為n-next[n]。

#include<iostream>
#include<string.h>
using namespace std;
int next[1000005];
char s[1000005];
void getnext(){
    int i=0,j=-1;
    next[0]=-1;
    int len=strlen(s);
    while(i<len){
        if(s[i]==s[j]||j==-1){
            i++;
            j++;
            next[i]=j;
        }
        else
            j=next[j];
    }
}
int main(){
    while(scanf("%s",s)>0){
        if(s[0]=='.')
            break;
        int len=strlen(s);
        getnext();
        if(len%(len-next[len])==0)
            printf("%d\n",len/(len-next[len]));
        else
            printf("1\n");
    }
    return 0;
}