1. 程式人生 > >【笨方法學PAT】1112 Stucked Keyboard (20 分)

【笨方法學PAT】1112 Stucked Keyboard (20 分)

一、題目

On a broken keyboard, some of the keys are always stucked. So when you type some sentences, the characters corresponding to those keys will appear repeatedly on screen for k times.

Now given a resulting string on screen, you are supposed to list all the possible stucked keys, and the original string.

Notice that there might be some characters that are typed repeatedly. The stucked key will always repeat output for a fixed ktimes whenever it is pressed. For example, when k=3, from the string thiiis iiisss a teeeeeest we know that the keys iand e might be stucked, but s

 is not even though it appears repeatedly sometimes. The original string could be this isss a teest.

Input Specification:

Each input file contains one test case. For each case, the 1st line gives a positive integer k (1<k≤100) which is the output repeating times of a stucked key. The 2nd line contains the resulting string on screen, which consists of no more than 1000 characters from {a-z}, {0-9} and _

. It is guaranteed that the string is non-empty.

Output Specification:

For each test case, print in one line the possible stucked keys, in the order of being detected. Make sure that each key is printed once only. Then in the next line print the original string. It is guaranteed that there is at least one stucked key.

Sample Input:

3
caseee1__thiiis_iiisss_a_teeeeeest

Sample Output:

ei
case1__this_isss_a_teest

二、題目大意

判斷壞鍵盤。

三、考點

vector/set

四、注意

1、注意壞鍵盤按照輸入順序輸出;

2、set和vector結合。

五、程式碼

#include<iostream>
#include<string>
#include<set>
#include<vector>
using namespace std;
int main() {
	//read
	int n;
	string s;
	cin >> n >> s;
	
	//judge
	set<char> set_good,set_bad,sset;
	vector<char> vec, v;
	for (int i = 0; i < s.length(); ) {
		int num = 0;
		char c = s[i];
		while (i < s.length() && s[i] == c) {
			num++;
			i++;
		}
		if (num%n == 0) {
			if (set_bad.find(c) == set_bad.end()) {
				set_bad.insert(c);
				vec.push_back(c);
			}
		}
			
		else
			set_good.insert(c);
	}

	//clear bad
	for (int i = 0; i < vec.size(); ++i) {
		if (set_good.find(vec[i]) == set_good.end()) {
			sset.insert(vec[i]);
			v.push_back(vec[i]);
		}
	}

	//output
	for (int i = 0; i < v.size(); ++i)
		cout << v[i];

	if(sset.size()!=0)
		cout << endl;

	for (int i = 0; i < s.length(); ++i){
		if (sset.find(s[i]) == sset.end()) {
			cout << s[i];
		}
		else {
			cout << s[i];
			i += n - 1;
		}
	}

	system("pause");
	return 0;
}