1. 程式人生 > >【笨方法學PAT】1036 Boys vs Girls (25 分)

【笨方法學PAT】1036 Boys vs Girls (25 分)

一、題目

This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N lines of student information. Each line contains a student's name

genderID and grade, separated by a space, where name and ID are strings of no more than 10 characters with no space, gender is either F (female) or M (male), and grade is an integer between 0 and 100. It is guaranteed that all the grades are distinct.

Output Specification:

For each test case, output in 3 lines. The first line gives the name and ID of the female student with the highest grade, and the second line gives that of the male student with the lowest grade. The third line gives the difference grade​F​​−grade​M​​. If one such kind of student is missing, output Absent

 in the corresponding line, and output NA in the third line instead.

Sample Input 1:

3
Joe M Math990112 89
Mike M CS991301 100
Mary F EE990830 95

Sample Output 1:

Mary EE990830
Joe Math990112
6

Sample Input 2:

1
Jean M AA980920 60

Sample Output 2:

Absent
Jean AA980920
NA

二、題目大意

求最大和最小。

三、考點

struct

四、注意

1、邊讀取,邊處理。

五、程式碼

#include<iostream>
#include<string>
using namespace std;
struct node {
	string name;
	char c;
	string calssid;
	int grade;
};
int main() {
	//read
	int n;
	cin >> n;
	node male, female;
	male.grade = 101;
	female.grade = -1;
	for (int i = 0; i < n; ++i) {
		node nd;
		cin >> nd.name >> nd.c >> nd.calssid >> nd.grade;
		if (nd.c == 'F') {
			if (nd.grade > female.grade)
				female = nd;
		}
		if (nd.c == 'M') {
			if (nd.grade < male.grade)
				male = nd;
		}
	}

	//output
	if (female.grade == -1)
		cout << "Absent" << endl;
	else
		cout << female.name << " " << female.calssid << endl;
	if (male.grade == 101)
		cout << "Absent" << endl;
	else
		cout << male.name << " " << male.calssid << endl;
	if (female.grade == -1 || male.grade == 101)
		cout << "NA" << endl;
	else
		cout << female.grade - male.grade << endl;

	system("pause");
	return 0;
}

六、程式碼