1. 程式人生 > >救濟金髮放(The Dole Queue,UVa33)

救濟金髮放(The Dole Queue,UVa33)

In a serious attempt to downsize (reduce) the dole queue, The New National Green Labour Rhinoceros Party has decided on the following strategy. Every day all dole applicants will be placed in a large circle, facing inwards. Someone is arbitrarily chosen as number 1, and the rest are numbered counter-clockwise up to N (who will be standing on 1's left). Starting from 1 and moving counter-clockwise, one labour official counts off k applicants, while another official starts from N and moves clockwise, counting m applicants. The two who are chosen are then sent off for retraining; if both officials pick the same person she (he) is sent off to become a politician. Each official then starts counting again at the next available person and the process continues until no-one is left. Note that the two victims (sorry, trainees) leave the ring simultaneously, so it is possible for one official to count a person already selected by the other official.

Input

Write a program that will successively read in (in that order) the three numbers (N, k and m; k, m > 0, 0 < N < 20) and determine the order in which the applicants are sent off for retraining. Each set of three numbers will be on a separate line and the end of data will be signalled by three zeroes (0 0 0).

Output

For each triplet, output a single line of numbers specifying the order in which people are chosen. Each number should be in a field of 3 characters. For pairs of numbers list the person chosen by the counter-clockwise official first. Separate successive pairs (or singletons) by commas (but there should not be a trailing comma).

Sample input

10 4 3
0 0 0

Sample output

tex2html_wrap_inline34 4 tex2html_wrap_inline34 8, tex2html_wrap_inline34 9 tex2html_wrap_inline34 5, tex2html_wrap_inline34 3 tex2html_wrap_inline34 1, tex2html_wrap_inline34 2 tex2html_wrap_inline34 6, tex2html_wrap_inline50 10, tex2html_wrap_inline34 7

where tex2html_wrap_inline50 represents a space.

#include<cstdio>
#include<string.h>
#include<algorithm>
using namespace std;
int a[20],n;
int go(int b,int c,int d)
{
	while(d--)
	{
		do{
			b=(b+c+n-1)%n+1; //順時針走或者逆時針走的關鍵!!!自己可以演示一下過程。。。 
		}
		while(a[b]==0);  //走到下一個非0數字,遇到已經走過的數字,繼續執行do語句。 
	}
	return b;   //返回經過d步後所停留的位置。 
}
int main()
{
	int k,m,t,p1,p2;
	while(scanf("%d%d%d",&n,&k,&m)&&n)
	{
		t=n;  //t表示剩下的人數 。 
		p1=n,p2=1;
		memset(a,0,sizeof(a));
		for(int i=1;i<=n;i++)
		{
			a[i]=i;
		}
		while(t)
		{
			p1=go(p1,1,k);
			printf("%3d",p1);
			t--;
			p2=go(p2,-1,m);
			if(p2!=p1)
			{
			    printf("%3d",p2);
			    t--;
		    }
		    a[p1]=a[p2]=0; //標記走過的位置 。 
		    if(t) printf(",");
		}
		printf("\n");
	}
}