1. 程式人生 > >HDU 1026.Ignatius and the Princess I【BFS廣度優先搜尋+優先佇列+前驅記錄】【8月16】

HDU 1026.Ignatius and the Princess I【BFS廣度優先搜尋+優先佇列+前驅記錄】【8月16】

Ignatius and the Princess I

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 17327    Accepted Submission(s): 5552
Special Judge


Problem Description The Princess has been abducted by the BEelzebub feng5166, our hero Ignatius has to rescue our pretty Princess. Now he gets into feng5166's castle. The castle is a large labyrinth. To make the problem simply, we assume the labyrinth is a N*M two-dimensional array which left-top corner is (0,0) and right-bottom corner is (N-1,M-1). Ignatius enters at (0,0), and the door to feng5166's room is at (N-1,M-1), that is our target. There are some monsters in the castle, if Ignatius meet them, he has to kill them. Here is some rules:

1.Ignatius can only move in four directions(up, down, left, right), one step per second. A step is defined as follow: if current position is (x,y), after a step, Ignatius can only stand on (x-1,y), (x+1,y), (x,y-1) or (x,y+1).
2.The array is marked with some characters and numbers. We define them like this:
. : The place where Ignatius can walk on.
X : The place is a trap, Ignatius should not walk on it.
n : Here is a monster with n HP(1<=n<=9), if Ignatius walk on it, it takes him n seconds to kill the monster.

Your task is to give out the path which costs minimum seconds for Ignatius to reach target position. You may assume that the start position and the target position will never be a trap, and there will never be a monster at the start position.

Input The input contains several test cases. Each test case starts with a line contains two numbers N and M(2<=N<=100,2<=M<=100) which indicate the size of the labyrinth. Then a N*M two-dimensional array follows, which describe the whole labyrinth. The input is terminated by the end of file. More details in the Sample Input.

Output For each test case, you should output "God please help our poor hero." if Ignatius can't reach the target position, or you should output "It takes n seconds to reach the target position, let me show you the way."(n is the minimum seconds), and tell our hero the whole path. Output a line contains "FINISH" after each test case. If there are more than one path, any one is OK in this problem. More details in the Sample Output.

Sample Input 5 6 .XX.1. ..X.2. 2...X. ...XX. XXXXX. 5 6 .XX.1. ..X.2. 2...X. ...XX. XXXXX1 5 6 .XX... ..XX1. 2...X. ...XX. XXXXX.
Sample Output It takes 13 seconds to reach the target position, let me show you the way. 1s:(0,0)->(1,0) 2s:(1,0)->(1,1) 3s:(1,1)->(2,1) 4s:(2,1)->(2,2) 5s:(2,2)->(2,3) 6s:(2,3)->(1,3) 7s:(1,3)->(1,4) 8s:FIGHT AT (1,4) 9s:FIGHT AT (1,4) 10s:(1,4)->(1,5) 11s:(1,5)->(2,5) 12s:(2,5)->(3,5) 13s:(3,5)->(4,5) FINISH It takes 14 seconds to reach the target position, let me show you the way. 1s:(0,0)->(1,0) 2s:(1,0)->(1,1) 3s:(1,1)->(2,1) 4s:(2,1)->(2,2) 5s:(2,2)->(2,3) 6s:(2,3)->(1,3) 7s:(1,3)->(1,4) 8s:FIGHT AT (1,4) 9s:FIGHT AT (1,4) 10s:(1,4)->(1,5) 11s:(1,5)->(2,5) 12s:(2,5)->(3,5) 13s:(3,5)->(4,5) 14s:FIGHT AT (4,5) FINISH God please help our poor hero. FINISH 思路:如果正向搜尋,需要逆向輸出,因此採用逆向搜尋,並記錄前驅。DFS會超時。
#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
const int MAX = 105;
struct Pos
{
    int x, y, time;
    friend bool operator< (Pos a, Pos b)
    {
        return a.time > b.time;
    }
};
struct Pre//記錄前驅
{
    int x, y;
}pre[MAX][MAX];
int N, M, vis[MAX][MAX];
char Map[MAX][MAX];
int x_x[4] = {-1, 0, 1, 0};//四方向搜尋
int y_y[4] = {0, 1, 0, -1};
int main()
{
    while(scanf("%d %d", &N, &M) != EOF)
    {
        memset(vis, 0, sizeof(vis));
        priority_queue <Pos> que;
        for(int i = 0;i < N; ++i) scanf("%s", Map[i]);
        Pos top, next;
        pre[N-1][M-1].x = -1;
        top.x = N-1;
        top.y = M-1;
        if(Map[N-1][M-1] == '.') top.time = 0;//出口位置可能不是'.'
        else top.time = Map[N-1][M-1]-'0';
        que.push(top);
        vis[N-1][M-1] = 1;
        bool Find = false;
        while(!que.empty())
        {
            top = que.top();
            que.pop();
            if(top.x == 0 && top.y == 0)
            {
                Find = true;
                printf("It takes %d seconds to reach the target position, let me show you the way.\n", top.time);
                int x = 0, y = 0, step = 1;
                while(pre[x][y].x != -1)//搜前驅,直到找到終點
                {
                    int tx = pre[x][y].x;
                    int ty = pre[x][y].y;
                    printf("%ds:(%d,%d)->(%d,%d)\n", step++, x, y, tx, ty);
                    if(Map[tx][ty] != '.')
                    {
                        int k = Map[tx][ty]-'0';
                        for(int j = 0;j < k; ++j) printf("%ds:FIGHT AT (%d,%d)\n", step++, tx, ty);
                    }
                    x = tx;
                    y = ty;
                }
                break;
            }
            else
            {
                for(int i = 0;i < 4; ++i)//四方向搜尋
                {
                    next.x = top.x+x_x[i];
                    next.y = top.y+y_y[i];
                    if(next.x < 0 || next.y < 0 || next.x >= N || next.y >= M) continue;
                    if(vis[next.x][next.y] || Map[next.x][next.y] == 'X') continue;
                    vis[next.x][next.y] = 1;
                    if(Map[next.x][next.y] == '.') next.time = top.time+1;
                    else next.time = top.time+1+Map[next.x][next.y]-'0';
                    pre[next.x][next.y].x = top.x;//記錄前驅
                    pre[next.x][next.y].y = top.y;
                    que.push(next);
                }
            }
        }
        if(!Find) printf("God please help our poor hero.\n");
        printf("FINISH\n");
    }
    return 0;
}