1. 程式人生 > >POJ 2481.Cows【樹狀陣列】【5月10】

POJ 2481.Cows【樹狀陣列】【5月10】

Cows
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 15943 Accepted: 5308

Description

Farmer John's cows have discovered that the clover growing along the ridge of the hill (which we can think of as a one-dimensional number line) in his field is particularly good.

Farmer John has N cows (we number the cows from 1 to N). Each of Farmer John's N cows has a range of clover that she particularly likes (these ranges might overlap). The ranges are defined by a closed interval [S,E].

But some cows are strong and some are weak. Given two cows: cowi
and cowj, their favourite clover range is [Si, Ei] and [Sj, Ej]. If Si <= Sj and Ej <= Ei and Ei - Si > Ej - Sj, we say that cowi is stronger than cowj.

For each cow, how many cows are stronger than her? Farmer John needs your help!

Input

The input contains multiple test cases.
For each test case, the first line is an integer N (1 <= N <= 105
), which is the number of cows. Then come N lines, the i-th of which contains two integers: S and E(0 <= S < E <= 105) specifying the start end location respectively of a range preferred by some cow. Locations are given as distance from the start of the ridge.

The end of the input contains a single 0.

Output

For each test case, output one line containing n space-separated integers, the i-th of which specifying the number of cows that are stronger than cowi.

Sample Input

3
1 2
0 3
3 4
0

Sample Output

1 0 0
有N個區間,求包含當前區間的區間個數:

思路:

將區間按照右端點從大到小排序,比較左端點,樹狀陣列儲存,不斷維護樹狀陣列:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAX = 100005;
struct ss
{
    int x, y, id;
}cows[MAX];
bool cmp(ss a, ss b)
{
    if(a.y > b.y) return true;
    else if(a.y == b.y && a.x < b.x) return true;
    else return false;
}
int N, maxn, xi, yi, tree[MAX], ans[MAX];
void Insert(int pos)
{
    while(pos <= maxn+1)
    {
        tree[pos] ++;
        pos += pos&(-pos);
    }
}
int Query(int pos)
{
    int sum = 0;
    while(pos > 0)
    {
        sum += tree[pos];
        pos -= pos&(-pos);
    }
    return sum;
}
int main()
{
    while(scanf("%d", &N) != EOF && N)
    {
        maxn = -1;
        memset(ans, 0, sizeof(ans));
        memset(tree, 0, sizeof(tree));
        for(int i = 0;i < N; ++i)
        {
            scanf("%d %d", &xi, &yi);
            cows[i].x = xi+1;
            cows[i].y = yi+1;
            cows[i].id = i+1;
            if(maxn < cows[i].y) maxn = cows[i].y;
        }
        sort(cows, cows+N, cmp);
        Insert(cows[0].x);
        for(int i = 1;i < N; ++i)
        {
            if(cows[i].x == cows[i-1].x && cows[i].y == cows[i-1].y) ans[cows[i].id] = ans[cows[i-1].id];
            else ans[cows[i].id] = Query(cows[i].x);
            Insert(cows[i].x);
        }
        for(int i = 1;i <= N; ++i)
        {
            if(i != 1) cout <<" ";
            cout << ans[i];
        }
        cout << endl;
    }
    return 0;
}