1. 程式人生 > >HDU 1059.Dividing【多重揹包+篩選(DP)】【3月17】

HDU 1059.Dividing【多重揹包+篩選(DP)】【3月17】

Dividing

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 22051    Accepted Submission(s): 6208


Problem Description Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value. 
Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.

Input Each line in the input describes one collection of marbles to be divided. The lines consist of six non-negative integers n1, n2, ..., n6, where ni is the number of marbles of value i. So, the example from above would be described by the input-line ``1 0 1 2 0 0''. The maximum total number of marbles will be 20000. 

The last line of the input file will be ``0 0 0 0 0 0''; do not process this line.

Output For each colletcion, output ``Collection #k:'', where k is the number of the test case, and then either ``Can be divided.'' or ``Can't be divided.''. 

Output a blank line after each test case.

Sample Input 1 0 1 2 0 0 1 0 0 0 1 1 0 0 0 0 0 0
Sample Output Collection #1: Can't be divided. Collection #2: Can be divided. 題目意思就是要把價值為1/2/3/4/5/6的若干個石頭分成價值相等的兩堆,問是否可以,具體操作看程式碼:
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int main()
{
    int kase = 1, sum, MAXN;
    int num[7], dp[60010];
    while(1)
    {
        sum = 0;
        for(int i = 1;i <= 6; ++i)
        {
            scanf("%d", &num[i]);
            sum += num[i]*i;
        }
        if(sum == 0) break;
        else if(sum%2 == 1)//總價值為奇數,肯定無法平分
        {
            printf("Collection #%d:\nCan't be divided.\n\n", kase++);
            continue;
        }
        else
        {
            printf("Collection #%d:\n", kase++);
            memset(dp, 0, sizeof(dp));
            MAXN = sum/2;
            //多重揹包,這次我們不儲存價值,而是看當前價值能否湊出來
            for(int i = 0;i <= MAXN && i <= num[1]; ++i) dp[i] = 1;
            for(int i = 2;i <= 6; ++i)
            {
                for(int j = MAXN; j >= 0; --j)
                {
                    if(dp[j] == 0) continue;
                    for(int k = 1; k <= num[i]; ++k)
                    {
                        if(k*i+j > MAXN) break;//超範圍
                        if(dp[k*i+j] == 1) break;//去重
                        dp[k*i+j] = 1;
                    }
                }
            }
            if(dp[MAXN]) cout <<"Can be divided.\n\n";
            else cout <<"Can't be divided.\n\n";
        }
    }
    return 0;
}