1. 程式人生 > >北大ACM 2159 Ancient Cipher——這題一點都不水!!!!

北大ACM 2159 Ancient Cipher——這題一點都不水!!!!

Ancient Cipher
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 26102 Accepted: 8592

Description

Ancient Roman empire had a strong government system with various departments, including a secret service department. Important documents were sent between provinces and the capital in encrypted form to prevent eavesdropping. The most popular ciphers in those times were so called substitution cipher and permutation cipher. 
Substitution cipher changes all occurrences of each letter to some other letter. Substitutes for all letters must be different. For some letters substitute letter may coincide with the original letter. For example, applying substitution cipher that changes all letters from 'A' to 'Y' to the next ones in the alphabet, and changes 'Z' to 'A', to the message "VICTORIOUS" one gets the message "WJDUPSJPVT". 
Permutation cipher applies some permutation to the letters of the message. For example, applying the permutation <2, 1, 5, 4, 3, 7, 6, 10, 9, 8> to the message "VICTORIOUS" one gets the message "IVOTCIRSUO". 
It was quickly noticed that being applied separately, both substitution cipher and permutation cipher were rather weak. But when being combined, they were strong enough for those times. Thus, the most important messages were first encrypted using substitution cipher, and then the result was encrypted using permutation cipher. Encrypting the message "VICTORIOUS" with the combination of the ciphers described above one gets the message "JWPUDJSTVP". 
Archeologists have recently found the message engraved on a stone plate. At the first glance it seemed completely meaningless, so it was suggested that the message was encrypted with some substitution and permutation ciphers. They have conjectured the possible text of the original message that was encrypted, and now they want to check their conjecture. They need a computer program to do it, so you have to write one.

Input

Input contains two lines. The first line contains the message engraved on the plate. Before encrypting, all spaces and punctuation marks were removed, so the encrypted message contains only capital letters of the English alphabet. The second line contains the original message that is conjectured to be encrypted in the message on the first line. It also contains only capital letters of the English alphabet. 
The lengths of both lines of the input are equal and do not exceed 100.

Output

Output "YES" if the message on the first line of the input file could be the result of encrypting the message on the second line, or "NO" in the other case.

Sample Input

JWPUDJSTVP
VICTORIOUS

Sample Output

YES
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#define N 105

int cmp(const void *a, const void *b)
{
	return *(char*)a- *(char*)b;	
}
int cmp2(const void *a, const void *b)
{
	return *(int*)a- *(int*)b;	
}
int main()
{
    char first[N];
    char last[N], ch;
    int a[27]={0};
    int b[27]={0}, count = 1, k, k2, i;
    
	scanf("%s%s",last,first);
    
	qsort(first, strlen(first), sizeof(char), cmp);
	qsort(last, strlen(last), sizeof(char), cmp);
	
	for(i = 0, k = 0; first[i]!='\0';)
	{
		ch = first[i];
		while(first[++i] == ch)
			count++;
		a[k++] = count;
		count = 1;
	}
	for(i = 0, k2 = 0; last[i]!='\0'; )
	{
		ch = last[i];
		while(last[++i] == ch)
			count++;
		b[k2++] = count;
		count = 1;
	}	
	
	qsort(a, k, sizeof(int), cmp2);
	qsort(b, k2, sizeof(int), cmp2);
	
	for(i = 0; i < 27; i++)
		if(a[i]!=b[i])	break;
	if(i==27) printf("YES\n");
	else printf("NO\n");	
					
	
    system("pause");
    return 0;    
}


這道題目貢獻了20次WA,不過我覺得太值了,值得仔細地去推敲!