1. 程式人生 > >1119. Pre- and Post-order Traversals (30)【已知前序和後序求中序】

1119. Pre- and Post-order Traversals (30)【已知前序和後序求中序】

1119. Pre- and Post-order Traversals (30)

時間限制 400 ms
記憶體限制 65536 kB
程式碼長度限制 16000 B
判題程式 Special 作者 CHEN, Yue

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences, or preorder and inorder traversal sequences. However, if only the postorder and preorder traversal sequences are given, the corresponding tree may no longer be unique.

Now given a pair of postorder and preorder traversal sequences, you are supposed to output the corresponding inorder traversal sequence of the tree. If the tree is not unique, simply output any one of them.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=30), the total number of nodes in the binary tree. The second line gives the preorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first printf in a line "Yes" if the tree is unique, or "No" if not. Then print in the next line the inorder traversal sequence of the corresponding binary tree. If the solution is not unique, any answer would do. It is guaranteed that at least one solution exists. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input 1:
7
1 2 3 4 6 7 5
2 6 7 4 5 3 1
Sample Output 1:
Yes
2 1 6 4 7 3 5
Sample Input 2:
4
1 2 3 4
2 4 3 1
Sample Output 2:
No
2 1 3 4


#include <bits/stdc++.h>
#include<vector>
#define ms(x,y) memset(x,y,sizeof(x))
const int M=1e3+10;
using namespace std;
int i,j,k,n,m;
vector<int> pre,post,in;
int flag=1;

void getin(int prel,int prer,int posl,int posr)
{
    if(prel==prer){
      in.push_back(pre[prel]);
      return ;
    }
    if(pre[prel]==post[posr]){
     int i=prel+1;
     while(i<=prer&&pre[i]!=post[posr-1])i++;
     if(i-prel>1){
       getin(prel+1,i-1,posl,posl+i-prel-1-1);
     }
     else flag=0;
     in.push_back(post[posr]);
     getin(i,prer,posl+i-prel-1,posr-1);
    }
}

int main()
{
    scanf("%d",&n);
    pre.resize(n+1);post.resize(n+1);
    for(int i=1;i<=n;i++)scanf("%d",&pre[i]);
    for(int i=1;i<=n;i++)scanf("%d",&post[i]);
    getin(1,n,1,n);
    printf("%s\n%d",flag==1?"Yes":"No",in[0]);
    for(int i=1;i<in.size();i++)
        printf(" %d",in[i]);
        printf("\n");
    return 0;
}