1. 程式人生 > >poj 1201(查分約束之spfa)

poj 1201(查分約束之spfa)

Intervals
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 21758 Accepted: 8191

Description

You are given n closed, integer intervals [ai, bi] and n integers c1, ..., cn. 
Write a program that: 
reads the number of intervals, their end points and integers c1, ..., cn from the standard input, 
computes the minimal size of a set Z of integers which has at least ci common elements with interval [ai, bi], for each i=1,2,...,n, 
writes the answer to the standard output. 

Input

The first line of the input contains an integer n (1 <= n <= 50000) -- the number of intervals. The following n lines describe the intervals. The (i+1)-th line of the input contains three integers ai, bi and ci separated by single spaces and such that 0 <= ai <= bi <= 50000 and 1 <= ci <= bi - ai+1.

Output

The output contains exactly one integer equal to the minimal size of set Z sharing at least ci elements with interval [ai, bi], for each i=1,2,...,n.

Sample Input

5
3 7 3
8 10 3
6 8 1
1 3 1
10 11 1

Sample Output

6

Source

AC程式碼:

#include<cstring>
#include<iostream>
#include<stdio.h>
#include<stack>
using namespace std;
struct Node{
    int v,w;
    int next;
}Edge[150010];
int n,k;
int mx,mn;
int head[50005];
int spfa(){
    stack <int> st;
    int vis[50005],dis[50005];
    for(int i=mn;i<=mx;i++){
        vis[i]=0;
        dis[i]=-999999;
    }
    dis[mn]=0;
    st.push(mn);
    while(!st.empty()){
        int u=st.top(); st.pop();
        vis[u]=0;
        for(int i=head[u];i;i=Edge[i].next){
            int v=Edge[i].v;
            if(dis[v]<dis[u]+Edge[i].w){
                dis[v]=dis[u]+Edge[i].w;
                if(!vis[v]){
                    st.push(v);
                    vis[v]=1;
                }
            }
        }
    }
    return dis[mx];
}
int main(){
    while(scanf("%d",&n)!=EOF){
        memset(head,0,sizeof(head));
        mn=999999; mx=0;
        k=0;
        while(n--){
            int x,y,s;
            scanf("%d%d%d",&x,&y,&s);
            y++;
            mn=min(x,mn); mx=max(y,mx);
            k++;
            Edge[k].v=y; Edge[k].w=s;
            Edge[k].next=head[x];
            head[x]=k;
        }
        for(int i=mn;i<mx;i++){
            k++;
            Edge[k].v=i+1; Edge[k].w=0;
            Edge[k].next=head[i];
            head[i]=k;

            k++;
            Edge[k].v=i; Edge[k].w=-1;
            Edge[k].next=head[i+1];
            head[i+1]=k;
        }
        printf("%d\n",spfa());
    }
    return 0;
}